VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Problema com operação com contador - AJUDAAAAAAA!!!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
pehpy
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 31
Localização : Um lugar no meu do nada/SC
Data de inscrição : 02/07/2013

MensagemAssunto: Problema com operação com contador - AJUDAAAAAAA!!!   Ter Jul 02, 2013 2:19 am

fiz um contador onde pra cada opção escolhida do menu o contador tem q subtrair um número x do contador. tem dois menus. e o contador só tá subtraindo do ultimo menu.
olhem:

continua <- "s"
carga <- 100
enquanto (continua <> "n") faca
escreval ("************************Monitoramento de Carga************************")
escreval (" ")
escreval ("Quilometragem que Precisa Percorrer?")
leia (km)
limpatela
escreval ("---Tipo de estrada---")
escreval (" ")
escreval ("1 - Estrada de Chão")
escreval ("2 - Brita")
escreval ("3 - Calçada")
escreval ("4 - Gramado")
escreval (" ")
escreval ("Digite uma opção: ")
leia (opcao)
se (opcao = 1) entao
carga <- carga -10
se (opcao = 2) entao
carga <- carga -25
se(opcao = 3) entao
carga <- carga -1
se(opcao = 4) entao
carga <- carga -25
fimse
fimse
fimse
fimse
limpatela
escreval ("---Topografia---")
escreval ("5 - Subida")
escreval ("6 - Buracos")
escreval ("7 - Descida")
escreval (" ")
escreval ("Digite uma opção: ")
leia (opcao)
se (opcao = 5) entao
carga <- carga -14
se (opcao = 6) entao
carga <- carga -10
se (opcao = 7) entao
carga <- carga +15
fimse
fimse
fimse
limpatela
escreval ("Refazer tudo? S/N")
leia (continua)
limpatela
fimenquanto
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Problema com operação com contador - AJUDAAAAAAA!!!
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Problema - contador de visitas
» Grande problema a 2T
» Problema com Vapor da Trailtech
» Problema de cor de legenda e cores, de Admin, menbros..etc
» Problema com a imagem do rank

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: