VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Quicksort Não Recursivo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Jasper1
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 37
Localização : Sao Paulo
Data de inscrição : 05/11/2013

MensagemAssunto: Quicksort Não Recursivo   Ter Nov 05, 2013 9:40 pm

Olá estava procurando um jeito de fazer um quicksort. Não recursivo no visualg. Gostaria de saber se tem um jeito de fazer esse algoritmo funcionar ou eu devo começar do zero. Obrigado

Código:
algoritmo "semnome"
// Função :
// Autor :
// Data : 31/10/2013
// Seção de Declarações
var
vet : vetor [1..10] de inteiro
i,j,l,r,aux,arq,rt,ra : inteiro
pivo :inteiro
inicio
para i de 1 ate 10 faca
leia(vet[i])
fimpara
i<-1
j<-10
rt<-1
ra<-10
enquanto (i<j) faca
i<-rt
j<-ra
para arq de 1 ate 30 faca
i<-rt
j<-ra
pivo<-(vet[rt]+vet[ra]) div 2
enquanto (i<j) faca
enquanto (vet[i]<pivo) faca
i<-i+1
fimenquanto
enquanto (vet[j]>pivo) faca
j<-j-1
fimenquanto
se (i<=j) entao
aux<-vet[i]
vet[i]<-vet[j]
vet[j]<-aux
i<-i+1
j<-j-1
fimse
fimenquanto
se (j>rt) entao
rt<-rt
ra<-j
fimse
se (i<ra) entao
rt<-i
ra<-ra
fimse
fimpara
fimenquanto
para i de 1 ate 10 faca
escreval(vet[i]," ")
fimpara
// Seção de Comandos
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Quicksort Não Recursivo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: