VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Erro invalid floating point operation - Alguém sabe???

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
lucaslip
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 30
Localização : Recife
Data de inscrição : 14/11/2013

MensagemAssunto: Erro invalid floating point operation - Alguém sabe???   Qui Nov 14, 2013 4:43 pm

16:32:22

Olá companheiros,
só novo aqui no fórum e estou cursando o terceiro período de sistemas,
e não parei de fuçar no visualg,
um companheiro de trabalho está cursando também e está com uma dúvida
a questão é a seguinte fazer um algoritmo que tenha uma função e que essa função
seja de 2° grau, informando os valores das raízes e informando também quando não for uma raíz real,
eu fiz o código e quando eu o executo apresenta o seguinte erro

Arrow  Erro invalid floating point operation scratch 

o algoritmo está abaixo,



algoritmo "Equação do Segundo Grau Usando Função"
var
a,b,c,egrau: real //declaração das variáveis globais

           funcao fgrau(a,b,c: real):real //declaração da função

           var
           delta,raizdelta,x,x1,x2: real
           
Inicio



delta <- (b^2)-(4*a*c)
escreval ("Delta = ",delta)

se delta < 0 entao
escreval ("O valor de Delta é negativo, não possui Raiz real")
fimse

raizdelta <- raizQ(delta)

se delta = 0 entao
x <- ((-b)/(2*a))
escreval ("X =", x)
fimse

se delta > 0 entao
x1 <- ((-b)+(raizdelta))/(2*a)
escreval ("X1 =",x1)

x2 <- ((-b)-(raizdelta))/(2*a)
escreval ("X2 =",x2)
fimse


retorne fgrau

fimfuncao



inicio
  escreval("---- Equação do 2° Grau ----")
  escreval("Digite os valores que se pede abaixo")
  escreval ("Valor de A: ")
  leia (a)
  escreval ("Valor de B: ")
  leia (b)
  escreval ("Valor de C: ")
  leia (c)
  egrau <- fgrau(a,b,c)



fimalgoritmo

se alguém souber o que tem de errado nesse algoritmo eu ficaria grato,
Felicidades a todos!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Jasper1
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 37
Localização : Sao Paulo
Data de inscrição : 05/11/2013

MensagemAssunto: Re: Erro invalid floating point operation - Alguém sabe???   Sex Nov 15, 2013 5:06 pm

Olá tudo bem? Espero que isso o ajude. Boa sorte. Quando eu tentei. O erro apareceu somente quando eu deixava o delta negativo. Portanto você tem que deixar a função raizQ ser executada só quando o delta ser positivo.
Eu mudei algo na parte abaixo:
se (delta>=0) entao
raizdelta <- raizQ(delta)
fimse
Mas além do erro que você falou mesmo quando o delta é positivo ocorria outro erro. Por que o retorne fgrau não retorna algo que a função pode retornar. O que eu fiz foi colocar:
retorne delta
Mas você viu que do jeito que você fez um procedimento já seria o suficiente já que não há necessidade de retornar algo do jeito você fez o seu algoritmo?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Erro invalid floating point operation - Alguém sabe???
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Erro nas moedas de meu forum alguem sabe arrumar?
» Erro na queues!! Alguém sabe o q é isso?
» Alguém sabe um código html pra criar tipo um spoiler?
» alguem me passa o codigo css dessa barrinha?
» RB 2011 - ALGUÉM SABE COMO CONFIGURÁ-LA ?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Suporte-
Ir para: