VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Soma divisores: este programa está com erro

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Sandi
Novato
Novato


Feminino
Número de Mensagens : 2
Idade : 54
Localização : Ijuí/Rio Grande do Sul
Data de inscrição : 13/10/2014

MensagemAssunto: Soma divisores: este programa está com erro   Seg Out 13, 2014 6:22 pm

apenas o primeiro bloco está correto

algoritmo "somadivisores"
// Função :
// Autor :
// Data : 13/10/2014
// Seção de Declarações
var
cont, num, divnum: inteiro
somadiv, total: real
inicio
// Seção de Comandos
cont<-1
enquanto cont<=5 faca
escreva("Digite um número inteiro e positivo: ")
leia (num)
para divnum de 1 ate num passo 1 faca
se num mod divnum = 0 entao
escreval ("O seu divisor é: ", divnum)
somadiv<-(somadiv+divnum)
total<-somadiv-num
fimse
fimpara
cont<-cont+1
escreval ("A soma dos seus divisores é:", total)
escreval()
fimenquanto
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
miyabara
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 41
Localização : Pedra Preta - MT
Data de inscrição : 24/02/2015

MensagemAssunto: Re: Soma divisores: este programa está com erro   Ter Fev 24, 2015 11:04 am

algoritmo "somadivisores"
// Função : enquanto
// Autor : Willians Miyabara
// Data : 23/02/2015
// Seção de Declarações
var
cont, num, divnum: inteiro
somadiv, total: real
inicio
// Seção de Comandos
cont<-1
somadiv<-0 // Atribui o valor 0 para a variavel somadiv
enquanto cont<=5 faca
        somadiv<-0 // Após apresentar o resultado do bloco anterior tem que zerar a variavel.
        escreva("Digite um número inteiro e positivo: ")
        leia (num)
        para divnum de 1 ate num passo 1 faca
             se num mod divnum = 0 entao
                escreval ("O seu divisor é: ", divnum)
                somadiv<-(somadiv+divnum)
                total<-somadiv-num
             fimse
        fimpara
        cont<-cont+1
        escreval ("A soma dos seus divisores é:", total)
        escreval()
fimenquanto

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Soma divisores: este programa está com erro
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: