VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Altura de 6 pessoas

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Sandi
Novato
Novato


Feminino
Número de Mensagens : 2
Idade : 54
Localização : Ijuí/Rio Grande do Sul
Data de inscrição : 13/10/2014

MensagemAssunto: Altura de 6 pessoas   Seg Out 13, 2014 7:35 pm

Não consigo fazer a menor altura

algoritmo "semnome"
// Função :
// Autor :
// Data : 13/10/2014
// Seção de Declarações
var
cont, altura, maior, menor: inteiro
soma, media: real
inicio
// Seção de Comandos
cont<-1
enquanto cont<=6 faca
escreval ("Digite a altura:")
leia (altura)
se (altura>maior) entao
maior<-altura
fimse
se (altura<menor) entao
menor<-altura
fimse
soma<-soma+altura
media<-soma/6
cont<-cont+1
fimenquanto
escreval ("A maior altura do grupo é:", maior)
escreval ("A menor altura do grupo é:", menor)
escreval ("A média de altura do grupo é:", media)
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
miyabara
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 41
Localização : Pedra Preta - MT
Data de inscrição : 24/02/2015

MensagemAssunto: Re: Altura de 6 pessoas   Ter Fev 24, 2015 10:55 am

algoritmo "Maior e Menor Altura"
// Função : Enquanto
// Autor : Willians Miyabara
// Data : 23/02/2015
// Seção de Declarações
var
cont: inteiro
soma, media,altura, maior, menor: real

inicio
// Seção de Comandos
cont<-1
enquanto cont<=6 faca
        escreval ("Digite a altura:")
        leia (altura)
        se cont=1 entao // Tem que fazer as 2 alturas serem atribuidas na primeira leitura
           maior<-altura
           menor<-altura
        fimse

        se (altura>maior) entao
           maior<-altura
        fimse
        se (altura<menor) entao
           menor<-altura
        fimse
        soma<-soma+altura
        media<-soma/6
        cont<-cont+1
fimenquanto

escreval ("A maior altura do grupo é:", maior)
escreval ("A menor altura do grupo é:", menor)
escreval ("A média de altura do grupo é:", media)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Altura de 6 pessoas
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: