VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Dúvida Matriz.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
felipeluis
Novato
Novato
avatar

Número de Mensagens : 7
Data de inscrição : 28/10/2007

MensagemAssunto: Dúvida Matriz.   Qua Out 31, 2007 4:11 pm

Preciso da seguinte matriz:

X O X O X O X
O X O X O X O
X O X O X O X
O X O X O X O
X O X O X O X

eu fiz deu certo e tudo mas não sei se nao eh a logica que tem q usar
algoritmo "semnome"
// Função :
// Autor :
// Data : 31/10/2007
// Seção de Declarações
var


coluna, x : inteiro


inicio
// Seção de Comandos
para x de 1 ate 35 faca
x <- x+1
coluna <- coluna+1
se ( x mod 2 = 0 ) entao
Escreva ("O ")
senao
Escreva ("X ")
fimse
se (coluna % 7 =0 ) entao
Escreval ()
fimse
fimpara
fimalgoritmo

agora a outra lógica



algoritmo "semnome"
// Função :
// Autor :
// Data : 31/10/2007
// Seção de Declarações
var

vet : vetor[1..30]
linha, coluna : inteiro
x : inteiro


inicio
// Seção de Comandos
para linha de 1 ate 5 faca
Escreval ()
para coluna de 1 ate 7 faca
x <- x+1
se ( x mod 2 = 0 ) entao
Escreva ("O ")
senao
Escreva ("X ")
fimse
fimpara
fimpara
fimalgoritmo



queria saber qual das duas lógicas é mais adequada
Voltar ao Topo Ir em baixo
Ver perfil do usuário
shaohot
Novato
Novato


Número de Mensagens : 7
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Dúvida Matriz.   Qua Out 31, 2007 4:13 pm

felipeluis escreveu:
Preciso da seguinte matriz:

X O X O X O X
O X O X O X O
X O X O X O X
O X O X O X O
X O X O X O X

eu fiz deu certo e tudo mas não sei se nao eh a logica que tem q usar
algoritmo "semnome"
// Função :
// Autor :
// Data : 31/10/2007
// Seção de Declarações
var


coluna, x : inteiro


inicio
// Seção de Comandos
para x de 1 ate 35 faca
x <- x+1
coluna <- coluna+1
se ( x mod 2 = 0 ) entao
Escreva ("O ")
senao
Escreva ("X ")
fimse
se (coluna % 7 =0 ) entao
Escreval ()
fimse
fimpara
fimalgoritmo

agora a outra lógica



algoritmo "semnome"
// Função :
// Autor :
// Data : 31/10/2007
// Seção de Declarações
var

vet : vetor[1..30]
linha, coluna : inteiro
x : inteiro


inicio
// Seção de Comandos
para linha de 1 ate 5 faca
Escreval ()
para coluna de 1 ate 7 faca
x <- x+1
se ( x mod 2 = 0 ) entao
Escreva ("O ")
senao
Escreva ("X ")
fimse
fimpara
fimpara
fimalgoritmo



queria saber qual das duas lógicas é mais adequada
As duas lógicas estão corretas
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Dúvida Matriz.   Qua Out 31, 2007 4:25 pm

Parabéns felipe, as lógicas são funcionais.

Mas eu imagino que queiram que você use uma matriz de verdade (um vetor dentro de outro). Não sabe o que é isso?

Observe a declaração de uma matriz:

Nome_Da_Matriz : vetor[1..10,1..10] de inteiro

Significa que é um vetor com 10 células, e cada célula contém 10 células. Por exemplo, a célula 3 da célula 5 é o mesmo que:

Nome_Da_Matriz[5,3]

No seu exercício você poderia fazer algo como:

Nome_Da_Matriz[linha,coluna] <- "X"

Caso não queiram que você resolva dessa forma, use o 1° algoritmo que você fez, pois no 2° você declarou uma variável inútil: vet
Voltar ao Topo Ir em baixo
Ver perfil do usuário
felipeluis
Novato
Novato
avatar

Número de Mensagens : 7
Data de inscrição : 28/10/2007

MensagemAssunto: Re: Dúvida Matriz.   Qua Out 31, 2007 6:18 pm

É isso mesmo, valeu...
que bom que minhas logicas estavam certas...mas acho que é com vetor.
Quanto ao segundo algoritmo, era só tira-la, mas já fiz com vetor mesmo... Valeu!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Dúvida Matriz.   Qua Out 31, 2007 6:20 pm

Problema resolvido. Tópico trancado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Dúvida Matriz.   

Voltar ao Topo Ir em baixo
 
Dúvida Matriz.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Idéia de Camisa do Time para Projeto Vida Do futebol
» [Aula] Array e Matriz em GML
» [Tutorial] HUD com Corações de Health/Vida/Sangue
» A Vida Secreta das Abelhas - DVDRip RMVB - Dublado
» Dúvida "Fale Conosco"

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: