VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Multiplicar primos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Multiplicar primos   Sab Nov 03, 2007 9:41 am

Escrever um algoritmo/programa que calcula e escreve o produto dos números primos entre 92 e 1478.

Eu fiz este algoritmo só que estou com dúvidas em como determinar se um numero e primo ou não.
Eu sei que tenho que usar a função se.
Eu sei que preciso colocar um contador para multiplicar os numeros primos mais não sei como.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar primos   Seg Nov 05, 2007 12:24 pm

Faça um para que começa do número subtraído em 1 e vai até 2, e dentro verifique se o número é divisível pela posição do 'para', por exemplo

para i de num-1 ate 2 faca
se (num % i = 0) entao
Não é primo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar primos   Ter Nov 06, 2007 12:15 pm

Eu fiz assim

Mais esta dando divion by zero

O que esta errado?

para i de n-1 ate 1478 faca
se (n % i = 0) entao
escreva("Não é primo")
fimse
se (n%i=0) entao
acm <- acm * n
fimse

escreval(acm)
fimpara
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar primos   Ter Nov 06, 2007 7:02 pm

Quais os valores de 'n' e 'i' ? Você declarou algum valor a elas?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar primos   Ter Nov 06, 2007 7:06 pm

Não.
O i e o contador.
Ou no lugar do i eu coloco n?
Mais o algoritmo esta certo?
Tirando o erro do n?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar primos   Qua Nov 07, 2007 9:40 am

Eu alterei o algoritmo para esta estrutura e ele só me mostra 92 e não me mostra os outros numeros primos.
Como fazer para mostrar os outros primos multiplicados?

acm <- 1
n <- 92
para i de n-1 ate 1478 faca
se (n % i = 0) entao
escreva("Não é primo")
fimse
se (n%i=0) entao
acm <- acm * n
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar primos   Sab Nov 10, 2007 11:04 pm

Porque você fez 2 "se" com a mesma condição?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar primos   Seg Nov 12, 2007 9:04 am

Eu fiz isso agora e continua dando o mesmo erro


acm <- 1
para n de 92 ate 1477 passo 1 faca
primo <- 1
para i de 92 ate (n-1) faca
se (primo = 1) entao
acm <- acm * n
escreva ("achei um primo ", n)
escreva ("O valor da multiplicacao eh: ", acm)
fimse
fimpara
fimpara
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar primos   Ter Nov 13, 2007 7:30 pm

Problema finalmente resolvido
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Multiplicar primos   

Voltar ao Topo Ir em baixo
 
Multiplicar primos
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Multiplicar o widget de votação
» Multiplicar widget de votação
» [TUTORIAL] Multiplicar os widgets de novidades
» [TUTORIAL] Multiplicar o widgets de últimos assuntos
» [Resolvidos]Multiplicação-multiplicar caixas de textos no VBA

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: