VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ordenar vetor

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Ordenar vetor   Sab Nov 03, 2007 10:02 am

Eu vi a duvida anterior de ordenação de vetor mais não entendi bem

Pois o código que você postou e apenas para ordenar 2 vetores ou 1 vetor apenas?
Eu poderia fazer assim?


para i de 1 ate 5 faca
para i de i+1 ate 5 faca
se numeros[i] > numeros[i] entao
copianumero <- numeros[i]
numeros[i] <- numeros[a]
numeros[i] <- copianumero
fimse
fimpara
fimpara

Ou o código ficaria errado?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Ordenar vetor   Sab Nov 03, 2007 10:10 am

Eu fiz assim mais não esta certo na hora de ordenar em ordem decrecente o que esta errado?

algoritmo "ordenaçao"
//Função: Ordenar vetor
//Autor: Gustavo Rodrigues Torre
//Data: 3/11/07
var
//Declaração das variáveis
i,j,tmp: inteiro
num: vetor[1..15] de inteiro

inicio
//Seção de declarações
escreval ("Digite os numeros")
para i de 1 ate 15 faca
leia(num[i])
fimpara

j <- 15
enquanto j > 1 faca
para i de 1 ate j-1 faca
se num[i] > num[i+1] entao
tmp <- num[i]
num[i] <- num[i+1]
num[i+1] <- tmp
fimse
fimpara
j <- j-1
fimenquanto

escreval ("------Crescente-------")

para i de 1 ate 15 faca
escreval (num[i])
fimpara

escreval ("------decrescente-------")

j <- 15
enquanto j > 15 faca
para i de 1 ate j-1 faca
se num[i] < num[i+1] entao
tmp <- num[i]
num[i] <- num[i+1]
num [i+1] <- tmp
fimse
fimpara
j <- j-1
fimenquanto
para i de 1 ate 15 faca
escreval (num[i])
fimpara
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenar vetor   Sab Nov 03, 2007 6:05 pm

Observe o erro em seu algoritmo:

j <- 15
enquanto j > 15 faca


O que estiver dentro desse enquanto nunca vai acontecer, pois você disse que j = 15, então j não é maior que 15

Apenas troque esse 'enquanto' por esse: enquanto j > 1 faca, e o algoritmo funcionará corretamente.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenar vetor   Dom Nov 04, 2007 1:59 am

Problema resolvido?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Ordenar vetor   Dom Nov 04, 2007 11:08 am

Resolvido
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenar vetor   Dom Nov 04, 2007 12:33 pm

Trancado.
Seção Suporte destinada a dúvidas de sintaxe, movido para seção pedidos de algoritmos.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Ordenar vetor   

Voltar ao Topo Ir em baixo
 
Ordenar vetor
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Ordenar em ordem crescendo campo MM/YYYY
» Ordenar dados (linhas) em Caixa de Combinação

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: