VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 PA

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: PA   Ter Nov 06, 2007 7:17 pm

Eu fiz o algoritmo de PA só que esta dando erro não sei pq
Quando eu coloco 3 termos ele só me mostra 2.
O que esta errado no código?

para a1 de a1 ate (ntermos*r) passo r faca

escreva(a1)
fimpara


fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: PA   Ter Nov 06, 2007 7:28 pm

Acho que já vi o meu erro
para a1 de a1 ate (ntermos*r) passo r faca

Eu mudei para isso
para a1 de 1 ate (ntermos*r) passo r faca

Mais ainda a PA não me mostra o 1º termo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: PA   Qua Nov 07, 2007 8:27 pm

Suporte escreveu:
Você usará um 'para' que começa de 'a1' e vai até o número de termos multiplicado pela razão (ntermos * r) passo r.

Como já disse, o para começa em a1, e não em 1

Na primeira tentativa você quase acertou

guga22 escreveu:
para a1 de a1 ate (ntermos*r) passo r faca

Mas a variável de controle não pode ser a1, pode ser qualquer variável do tipo initeiro como 'i', 'a' ou qualquer nome
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: PA   Qui Nov 08, 2007 9:26 am

Eu fiz assim:

para i de a1 ate (ntermos*r) passo r faca

escreva(i)
fimpara
E só me apresenta 2 termos e não me mostra o terceiro.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: PA   Sex Nov 09, 2007 9:43 am

Eu fiz assim agora
Mais a PA me retorna um termo a mais

para i de a1 ate ((ntermos*r)+a1) passo r faca

escreva(i)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: PA   Sex Nov 09, 2007 10:20 am

Acho que agora eu consegui
Confiram e podem trancar o tópico

algoritmo "PA"
// Função : Formar uma PA
// Autor : Gustavo Rodrigues Torre
// Data : 05/11/07
// Seção de Declarações
var
i, a1,ntermos, r : inteiro
inicio
// Seção de Comandos
escreva("Entre com o primeiro termo: ")
leia(a1)
escreva("Entre com a razão: ")
leia(r)
escreva("Entre com o numero de termos")
leia(ntermos)
para i de a1 ate (((ntermos-1)*r)+a1) passo r faca

escreva(i)
fimpara


fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: PA   Sab Nov 10, 2007 11:09 pm

Correto. Tópico trancado.
Seção Suporte destinada a dúvidas de sintaxe, movido para seção pedidos de algoritmos.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: PA   

Voltar ao Topo Ir em baixo
 
PA
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: