VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Soma elementos pares da Matriz

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Soma elementos pares da Matriz   Qui Nov 08, 2007 9:14 am

Este algoritmo não esta somando os elentos pares o que eu faço?
Onde esta o erro?

algoritmo "matriz e vetor"
// Função : Mostraz Matriz através de vetor
// Autor : Gustavo Rodrigues Torre
// Data : 31/10/2007
// Seção de Declarações
var
A: vetor[1..5] de inteiro
B : vetor[1..5,1..3] de inteiro
i,j,p,s,col2 : inteiro
fat : inteiro
inicio
// Seção de Comandos
repita
limpatela
Para i de 1 ate 5 faca
escreva("Digite um valor do elemento da linha" , i, "do vetor A: ")
leia (A[i])
B[i,1] <- A[i] + i
col2 <- 1
para s de 1 ate i faca
col2 <- col2 * A[i]
fimpara
B[i,2] <- A[i] ^ i
fat<-1

para j de 1 ate A[i] faca
fat <- fat * j
fimpara
B[i,3] <- fat
fimpara
escreval
escreval(" Vetor A Matriz B: ")
escreval

s <- 0

para i de 1 ate 5 faca
escreva(A[i]," ")
para j de 1 ate 3 faca
escreva (B[i,j]," ")
se (B[i,j] mod 2 = 0 ) entao
s <- s + 1
fimse
fimpara
escreval
fimpara
escreval
escreval("A matriz B tem ",s," elento(s) par(es)")
escreval("deseja continuar (1)Sim (0)Não")
leia(p)
ate(p=0)
escreval

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Soma elementos pares da Matriz   Sex Nov 09, 2007 9:45 am

O erro acho que esta na parte das variaveis
Me corrijam caso eu esteja errado.
E tambêm na parte de mostrar os pares ele me retorna 0
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Soma elementos pares da Matriz   Seg Nov 12, 2007 6:37 pm

Postei no envie um algoritmo para nos
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Soma elementos pares da Matriz   Seg Nov 12, 2007 7:17 pm

O que você precisa exatamente? Elabore mais o seu algoritmo, está dando erro no começo

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Soma elementos pares da Matriz   Seg Nov 12, 2007 7:48 pm

Eu preciso que ele me mostre quantos elemntos pares existem na matriz B.

Colocando assim
O algoritmo roda direitinho mostrando tudo o que o algoritmo deve fazer.

var
A: vetor[1..5] de inteiro
B : vetor[1..5,1..3] de real
i,j,p,s,col2 : inteiro
fat : inteiro
Só não conta os elementos pares
Mais quando eu mudo
var
A: vetor[1..5] de inteiro
B : vetor[1..5,1..3] de inteiro //real para inteiro
i,j,p,s,col2 : inteiro
fat : inteiro
O algoritmo não roda

Aqui esta o algoritmo rodando legal mas não mostrando a soma dos elementos pares

var
A: vetor[1..5] de inteiro
B : vetor[1..5,1..3] de real
i,j,p,s,col2 : inteiro
fat : inteiro
inicio
// Seção de Comandos
repita
limpatela
Para i de 1 ate 5 faca
escreva("Digite um valor do elemento da linha" , i, "do vetor A: ")
leia (A[i])
B[i,1] <- A[i] + i
col2 <- 1
para s de 1 ate i faca
col2 <- col2 * A[i]
fimpara
B[i,2] <- A[i] ^ i
//fimpara /Se tirar esse comentario o algoritmo não roda
fat<-1

para j de 1 ate A[i] faca
fat <- fat * j
fimpara
B[i,3] <- fat
fimpara
escreval
escreval(" Vetor A Matriz B: ")
escreval

s <- 0

para i de 1 ate 5 faca
escreva(A[i]," ")
para j de 1 ate 3 faca
escreva (B[i,j]," ")
se (B[i,j] mod 2 = 0 ) entao
s <- s + 1
fimse
fimpara
escreval
fimpara
escreval
escreval("A matriz B tem ",s," elento(s) par(es)")
escreval("deseja continuar (1)Sim (0)Não")
leia(p)
ate(p=0)
escreval
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Soma elementos pares da Matriz   

Voltar ao Topo Ir em baixo
 
Soma elementos pares da Matriz
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Aula] Array e Matriz em GML
» VPN PPTP com 1 matriz e 2 filial ?
» Mudar posição de alguns elementos
» Elementos não recebem propriedades css
» Adicionar elementos ao grupo sem acessar o painel de controle

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: