VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Multiplicar linha da Matriz

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Multiplicar linha da Matriz   Sex Nov 09, 2007 8:28 am

Faça um algoritmo que receba uma matriz A(6,6) e multiplica cada linha pelo elemento da diagonal principal daquela linha. O algoritmo deve retornar a matriz alterada.
Eu fiz o uso de um se mais não me retornou a linha multiplicada o que eu faço

se (i=j) entao
B[i] <- B[i] * i
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Sex Nov 09, 2007 4:36 pm

Defina diagonal principal da linha. De preferencia com um exemplo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Sex Nov 09, 2007 5:15 pm

Olha eu acho que e assim

4 6
5 3

4 e 3 são elementos da Diagonal Principal portanto

O algoritmo deverá multiplicar 4 * 6 e 5 * 3

Isto esta correto?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Sab Nov 10, 2007 11:17 pm

Pelo o que eu entendi, o que você precisa é do seguinte:
1 2 3 4 5
6 7 8 9 10
1 2 3 4 5
Onde 1, 7, 3 fazem parte da diagonal principal;
Agora multiplicar a linha, como seria:
Teria que pegar cada número da linha e multiplicar pelo número da diagonal pricinpal e imprimi-los, no nosso caso ficaria assim:
2*1; 3*1; 4*1; 5*1
6*7; 8*7; 9*7; 10*7
1*3; 2*3; 4*3; 5*3
É isso?
Ou multiplicar o produto da linha pelo número da diagonal principal? Se for, inclui o número da diagonal principal, ex:
1 4 9
5 2 8
6 3 7
No 1º caso faria:(1 * 4 * 9), depois multiplicaria pelo número da diagonal principal, nesse caso 1;
Ou seria (4 * 9) * número da diagonal principal.

Explique-nos como seria.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Seg Nov 12, 2007 6:06 pm

Eu to mei na dúvida se a diagonal principal deve ficar inalterada
E isto mesmo que deve ser feito.

2*1; 3*1; 4*1; 5*1
6*7; 8*7; 9*7; 10*7
1*3; 2*3; 4*3; 5*3
É isso?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Seg Nov 12, 2007 7:19 pm

Se você não sabe eu vou saber o que você quer?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Seg Nov 12, 2007 7:41 pm

E isto mesmo que deve ser feito.
Multiplicar o elemnto da linha pela da Diagonal principal sem alter a Diagonal principal

2*1; 3*1; 4*1; 5*1
6*7; 8*7; 9*7; 10*7
1*3; 2*3; 4*3; 5*3
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Qui Nov 15, 2007 3:22 pm

Acho que e assim confiram ai se estiver tudo certo podem trancar o tópico

algoritmo "DP multiplicado pelo linha "
//Função: Faça um algoritmo/programa que receba uma matriz A(6,6)
//e multiplica cada linha pelo elemento da diagonal principal daquela linha.
//O algoritmo/programa deve retornar a matriz alterada.
//Apresentar a matriz C.
// Data : 30/10/07
// Seção de Declarações
var
matA, matB : vetor [1..6,1..6] de real
i, j: inteiro //os índice sempre inteiro
inicio
// Seção de Comandos
Para i de 1 ate 6 faca
Para j de 1 ate 6 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matA[i,j])
fimpara
fimpara
escreval

para i de 1 ate 6 faca
para j de 1 ate 6 faca
se (i = j) entao
matB[i,j] <- matA[i,j]
senao
matB[i,j] <- matA[i,j] * matA[i,i]
fimse
fimpara
fimpara


escreva("A matriz A é:")
escreval
para i de 1 ate 6 faca
escreval
para j de 1 ate 6 faca
escreva (matA[i,j]," ")
fimpara
fimpara
escreval

Escreva("A matriz B é:")
escreval
Para i de 1 ate 6 faca
escreval
para j de 1 ate 6 faca
escreva (matB[i,j]," ")
fimpara
fimpara
escreval

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar linha da Matriz   Qui Nov 15, 2007 4:01 pm

Entendi, cada elemento da linha multiplicado pelo elemento da diagonal principal... Ta correto se for isso.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Multiplicar linha da Matriz   

Voltar ao Topo Ir em baixo
 
Multiplicar linha da Matriz
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Multiplicar linha a linha
» [Aula] Array e Matriz em GML
» Como retirar linha horizontal debaixo do menu?
» Remover linha indesejada na navbar do fórum
» Adcionar linha ou imagem em windgets

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: