VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Vetor

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Vetor   Sex Nov 09, 2007 8:32 am

Ler duas matrizes A e B do tipo vetor com 10 elementos. A matriz A deverá aceitar apenas a entrada de valores que sejam divisíveis por 2 e 3, enquanto a matriz B deverá aceitar apenas a entrada de valores que sejam múltiplo de 5. A entrada das matrizes deverá ser validada pelo programa e não pelo usuário. Construir uma matriz C de forma que a matriz C seja a junção das matrizes A e B, de modo que a matriz C contenha 20 elementos. Apresentar a matriz C.

Eu fiz o uso do se mais da erro toda vez que eu vou colocar valores divisiveis por 2 e 3 ao mesmo tempo e divisores de 5.
Onde esta o erro?

O código que eu estou usando e esse:

se (A[i]%2=0) e (A[i]%3=0) entao
A[i] <- A[i]
senao
escreva("Entre com valor correto")
leia(A[i])
C[i] <- (A[i])
fimse
se (B[i]%5=0) entao
C[i+10] <- B[i]
senao
escreva("Entre com valor correto")
leia(B[i])
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Vetor   Sex Nov 09, 2007 5:00 pm

Leia a resposta de seu tópico "Vetor multiplos de 5 e 3 e 2", se entender o que expliquei lá, fará esse algoritmo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Vetor   Sex Nov 09, 2007 5:16 pm

Já vi o seu post e coloquei outra duvida lá

Neste exemplo aqui o código ficari assim?

se (rand%2=0) e (randi%3=0) entao
A[i] <- A[i]
senao
C[i] <- (A[i])
fimse
se (randi%5<>0) entao
C[i+10] <- B[i]
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Vetor   Sab Nov 10, 2007 9:58 am

Resolvido esqueça o meu post
Eu já resolvi o problema
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Vetor   

Voltar ao Topo Ir em baixo
 
Vetor
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Visual G - Vetor decrescente
» [EPS]Damask Frames-Stock Vector

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: