VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Vetor compactado

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Vetor compactado   Sex Nov 09, 2007 8:35 am

Escrever um algoritmo que lê, um vetor V[20] e o escreve. Compacte, a seguir, o vetor Y, retirando dele todos os valores nulos ou negativos e escreva o vetor compactado.

Este vetor esta me retornando valores nulos no vetor Y
Eu fiz o uso do se

se (i<0) e (i=0) entao
Y[i] <- V[i] - 0
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Vetor compactado   Sex Nov 09, 2007 4:56 pm

Como o número representado pela variável 'i' pode ser < 0 e = 0 ao mesmo tempo?

Faça um 'para' que atribui os números do vetor V no vetor Y, com a seguinte condição: o número do vetor V for maior que 0

O único problema aparente deve ser definir até quanto vai esse 'para', já que você não sabe quantos números serão retirados do vetor. Recomendo que crie uma variável contadora que conte cada número retirado e faça o para dessa forma : para i de 1 ate 20-retirados faca
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Vetor compactado   Sex Nov 09, 2007 5:09 pm

Consegui fazer
fiz diferente e deu certo


j <- 1
para i de 1 ate 20 faca
se (V[i] > 0) entao
Y[j] <- V[i]
j <- j + 1
fimse
fimpara


escreval("Vetor Y compactado")
para i de 1 ate j-1 faca
escreval (Y[i])
fimpara
escreval

Pode trancar o tópico
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Vetor compactado   

Voltar ao Topo Ir em baixo
 
Vetor compactado
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Visual G - Vetor decrescente
» [EPS]Damask Frames-Stock Vector

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: