VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Vetor multiplos de 5 e 3 e 2

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Vetor multiplos de 5 e 3 e 2   Sex Nov 09, 2007 3:20 pm

Ler duas matrizes A e B do tipo vetor com 10 elementos. A matriz A deverá aceitar apenas a entrada de valores que sejam divisíveis por 2 e 3, enquanto a matriz B deverá aceitar apenas a entrada de valores que sejam múltiplo de 5. A entrada das matrizes deverá ser validada pelo programa e não pelo usuário. Construir uma matriz C de forma que a matriz C seja a junção das matrizes A e B, de modo que a matriz C contenha 20 elementos. Apresentar a matriz C.


Eu comecei a fazer só que da erro na hora de receber os multiplos

Eu fiz o uso da função se e me parece que esta errado.

se (A[i]%2=0) e (A[i]%3=0) entao
A[i] <- A[i]
senao
escreva("Entre com valor correto")
leia(A[i])
C[i] <- (A[i])
fimse
se (B[i]%5=0) entao
C[i+10] <- B[i]
senao
escreva("Entre com valor correto")
leia(B[i])
fimse

E mais uma coisa com outro algoritmo relacionado a este estava pedindo os não multiplos de 5 no vetor B.

Eu fiz o uso tambêm da função se e me parece que não esta rodando direito.

se (A[i]%2=0) e (A[i]%3=0) entao
A[i] <- A[i]
senao
escreva("Entre com valor correto")
leia(A[i])
C[i] <- (A[i])
fimse
se (B[i]%5<>0) entao
C[i+10] <- B[i]
senao
escreva("Entre com valor correto")
leia(B[i])
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Vetor multiplos de 5 e 3 e 2   Sex Nov 09, 2007 4:46 pm

leia(A[i]) ? Preste mais atenção no seu exercício:
A entrada das matrizes deverá ser validada pelo programa e não pelo usuário.

Use randi. enquanto o número que sair no randi % 3 for diferente de 0 ou % 2 for diferente de 0, ele fará randi novamente, dessa forma só entrará números divisíveis por 2 e 3. A mesma lógica se aplica à matriz B, e à esse outro exercício

para que o vetor C contenha a junção desses dois vetores, use dois 'paras' dessa forma

para i de 1 ate 10 faca
.......
fimpara
para i de 11 ate 20 faca
.......
fimpara
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Vetor multiplos de 5 e 3 e 2   Sex Nov 09, 2007 5:13 pm

Vamos por partes
Esta parte esta correta?

se (randi%2=0) e (randi%3=0) entao
A[i] <- A[i]
senao
C[i] <- (A[i])
fimse
se (randi%5=0) entao
C[i+10] <- B[i]
fimse

Depois vamos resolver as outras partes
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Vetor multiplos de 5 e 3 e 2   Sab Nov 10, 2007 9:57 am

Resolvido
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Vetor multiplos de 5 e 3 e 2   

Voltar ao Topo Ir em baixo
 
Vetor multiplos de 5 e 3 e 2
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Visual G - Vetor decrescente
» [EPS]Damask Frames-Stock Vector

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: