VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Matriz e Vetor

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Matriz e Vetor   Sab Nov 10, 2007 10:10 am

Escrever um algoritmo/programa que lê uma matriz M(6,6) e um valor A e multiplica a matriz M pelo valor A e coloca os valores da matriz multiplicados por A em um vetor de V(36) e escreve no final o vetor V.

Eu comecei a fazer só que o vetor só me apresenta 4 valores

Obs: Eu coloquei o código todo para que vocês vejam onde esta o meu erro.


Para i de 1 ate 6 faca
Para j de 1 ate 6 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matM[i,j])

//Erro nesta parte

escreva("Digite um valor para o A: ")
leia(a)
matM[i,j] <- matM[i,j] * a
V[i] <- matM[i,j]
fimpara
fimpara
escreval

escreva("A matriz A é:")
escreval
para i de 1 ate 6 faca
escreval
para j de 1 ate 6 faca
escreva (matM[i,j]," ")
fimpara
fimpara
escreval

//Erro nesta parte
Escreva("O vetor V:")
escreval
Para i de 1 ate 36 faca
escreval
escreva (V[i]," ")
fimpara
escreval
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Matriz e Vetor   Sab Nov 10, 2007 1:40 pm

Aqui está seu erro:

Para i de 1 ate 6 faca

Para j de 1 ate 6 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matM[i,j])

//Erro nesta parte

escreva("Digite um valor para o A: ")
leia(a)
matM[i,j] <- matM[i,j] * a
V[i] <- matM[i,j] //erro aqui!!!

Você está dizendo que V[i] receberá o valor multiplicado, mas se você verificar no 'para', i só vai até 6, então você só terá 6 valores em seu vetor.

Você não deve usar V[i], deve colocar uma variável acumuladora que conte quantos elementos existem na matriz e usar dessa forma:

V[acumuladora] <- matM[i,j]
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Matriz e Vetor   Ter Nov 13, 2007 2:06 pm

Olha ta aqui o algoritmo resolvido mais a matriz a esta aprecendo os valores multiplicados na matriz e aparece o vetor certo com 36 posições contendo os valores multiplicados por A

algoritmo "Matriz em vetor"
//Função: Escrever um algoritmo/programa que lê uma matriz M(6,6) e um
//valor A e multiplica a matriz M pelo valor A e coloca os valores da matriz
//multiplicados por A em um vetor de V(36) e escreve no final o vetor V.
//Apresentar a matriz C.
// Data : 30/10/07
// Seção de Declarações
var
matM : vetor [1..6,1..6] de inteiro
V : vetor[1..36] de inteiro
a,i, j, vacm : inteiro //os índice sempre inteiro
inicio
// Seção de Comandos
Para i de 1 ate 6 faca
Para j de 1 ate 6 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matM[i,j])

escreva("Digite um valor para o A: ")
leia(a)
matM[i,j] <- matM[i,j] * a
Vacm <- matM[i,j]

fimpara
fimpara
escreval

escreva("A matriz A é:")
escreval
para i de 1 ate 6 faca
escreval
para j de 1 ate 6 faca
escreva (matM[i,j]," ")
fimpara
fimpara
escreval

Escreva("O vetor V:")
escreval
Para i de 1 ate 36 faca
escreval
escreva (Vacm," ")
fimpara
escreval

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 2:11 pm

O amigo, pelo que observei toda vez que o usuario entrar com o valor de um elemento da matriz ele tambem tera que entrar com o valor de A. Esse A não deveria ser constante??

Se for isso mesmo que estou pensando, eu faria da seguinte maneira:

--> Faria a leitura do vetor A

Escreva ("Entre com o valor de A:")
leia (A)

--> Faria a leitura dos elementos da matriz, multiplicando-os pelo valor de A

para i de 1 ate 6 faca
para j de 1 ate 6 faca
limpatela
escreva ("Entre com o valor da linha", i, " e coluna", j, ":")
leia (matriz[i,j])
matriz[i,j] <- matriz[i,j] * A
fimpara
fimpara

--> Faria o vetor receber os elementos da matriz

aux <- 0
para i de 1 ate 6 faca
para j de 1 ate 6 faca
aux <- aux + 1
vet[aux] <- matriz[i,j]
fimpara
fimpara

--> Imprimiria o vetor A

para i de 1 ate 36 faca
escreva (vet[i])
fimpara

espero ter ajudado =)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 2:30 pm

Amigo acho que consegui resolver

Confira ai se isto o que vc estava tentando me dizer


algoritmo "Matriz em vetor"
//Função: Escrever um algoritmo/programa que lê uma matriz M(6,6) e um
//valor A e multiplica a matriz M pelo valor A e coloca os valores da matriz
//multiplicados por A em um vetor de V(36) e escreve no final o vetor V.
//Apresentar a matriz C.
// Data : 30/10/07
// Seção de Declarações
var
matM : vetor [1..6,1..6] de inteiro
V : vetor[1..36] de inteiro
a,i, j, aux : inteiro //os índice sempre inteiro
inicio
// Seção de Comandos
Para i de 1 ate 6 faca
Para j de 1 ate 6 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matM[i,j])
escreva("Digite um valor para o A: ")
leia(a)
matM[i,j] <- matM[i,j] * a
fimpara
fimpara

aux <- 0
para i de 1 ate 6 faca
para j de 1 ate 6 faca
aux <- aux + 1
v[aux] <- matM[i,j]
fimpara
fimpara

escreval

escreva("A matriz A é:")
escreval
para i de 1 ate 6 faca
escreval
para j de 1 ate 6 faca
escreva (matM[i,j]," ")
fimpara
fimpara
escreval

Escreva("O vetor V:")
escreval
Para i de 1 ate 36 faca
escreval
escreva (V[i]," ")
fimpara
escreval

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 2:49 pm

Guga,

esse a é um numero constante? se for constante nao existe a necessidade de toda vez digitar o mesmo valor. Neste caso a leitura do valor A deveria ser feita antes do primeiro para.

Caso o valor de A nao seja constante ai sim a leitura devera estar dentro do "para".

espero ter ajudado.


Última edição por em Qui Nov 15, 2007 2:51 pm, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 2:51 pm

Caso o valor de a seja constante.. deveria ficar da seguinte maneira:

escreva("Digite um valor para o A: ")
leia(a)
Para i de 1 ate 6 faca
Para j de 1 ate 6 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matM[i,j])
matM[i,j] <- matM[i,j] * a
fimpara
fimpara


desta forma nao seria necessario digitar toda vez o mesmo valor.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 3:06 pm

Agora vc me pegou o algoritmo pede para multiplicar pelo valor de A
Mais eu modifiquei aqui e funcinou legal.
Vou ver se o A e constante.
Mais obrigado pela ajuda.
E vc poderia tentar me ajudar a resolver o algoritmo que eu coloquei acho que assim: Mostrar elemntos pares na Matriz B ?

Abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 3:14 pm

esse elemento a deve ser constante sim..
deve ser multiplicacao de matriz por um escalar..
no caso o A seria o escalar.. =)

vo da um olhada sim nesse problema que vc falou, tentar ver o que posso fazer e posto la..

Resolvi o post "Multiplicar diagonal principal da matriz" de sua autoria tambem.

abracos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 3:16 pm

Eu dei uma olhada só que não comei a fazer a algoritmo ainda vou tentar resolver e posto lá para vc ver.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 3:17 pm

ok.. =)
vou fazer o maximo para ajudar.

abracos
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Matriz e Vetor   Qui Nov 15, 2007 3:18 pm

Problema resolvido
Pode trancar o tópico
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Matriz e Vetor   

Voltar ao Topo Ir em baixo
 
Matriz e Vetor
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Aula] Array e Matriz em GML
» Visual G - Vetor decrescente
» [Vetor] Retro Stars
» Meu vetor - Desenho
» VPN PPTP com 1 matriz e 2 filial ?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: