VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Login  
Compartilhe | 
 

 Vetor compactado 2

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens: 175
Data de inscrição: 27/10/2007

MensagemAssunto: Vetor compactado 2   Seg Nov 12, 2007 6:11 pm

Escrever um algoritmo/programa que lê um vetor V(20) e o escreve.
Retire, a seguir, os elementos em duplicata, compactando o vetor Y, e escrevendo o vetor compactado.

Eu fiz assim mais esta dando erro

.
.
.

j <- 1

para i de 1 ate 20 faca
se (V[i] = V[i]) entao
Y[j] <- V[i]
j <- j + 1
fimse
fimpara
.
.
.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores


Número de Mensagens: 126
Data de inscrição: 26/10/2007

MensagemAssunto: Re: Vetor compactado 2   Seg Nov 12, 2007 7:24 pm

guga22 escreveu:

se (V[i] = V[i]) entao
O que significa isso?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens: 175
Data de inscrição: 27/10/2007

MensagemAssunto: Re: Vetor compactado 2   Seg Nov 12, 2007 7:39 pm

E para verificar se um elemento e igual ao outro.
Isto esta errado?
E como ficaria o algoritmo corrigido?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores


Número de Mensagens: 126
Data de inscrição: 26/10/2007

MensagemAssunto: Re: Vetor compactado 2   Seg Nov 12, 2007 8:50 pm

Pense...

se (V[i] = V[i]) entao

tem alguma coisa MUITO errada...

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens: 175
Data de inscrição: 27/10/2007

MensagemAssunto: Re: Vetor compactado 2   Ter Nov 13, 2007 11:31 am

Eu fiz assim mais esta dando erro num para..faca

k <- 0
para i de 1 ate 20 faca
ncopia <- 1
para j de i+1 ate 20 faca
se(V[i] = V[j])
ncopia <- 0
fimse
fimpara
se (ncopia = 1) entao
Y[k] <- A[i]
k <- k+1
fimse
fimpara
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens: 175
Data de inscrição: 27/10/2007

MensagemAssunto: Re: Vetor compactado 2   Qui Nov 15, 2007 3:21 pm

Acho que agora consegui
Favor verificar se esta correto este algoritmo

algoritmo "semnome"
// Função :
// Autor :
// Data : 13/11/2007
// Seção de Declarações
var
v,Y : vetor [1..20] de inteiro
k,i,j: inteiro
c: inteiro
inicio
Para i de 1 ate 20 faca
escreva("Digite um valor do elemento da linha" , i,"do vetor K: ")
leia (v[i])
fimpara


escreval
escreval("Vetor V ")
escreval
para i de 1 ate 20 faca
escreval (" ",V[i])
fimpara
escreval
escreval

k <- 1
para i de 1 ate 20 faca
c <- 1
para j de i+1 ate 20 faca entao
se(V[i] = V[j]) entao
c <- 0
interrompa
fimse
fimpara
se (c = 1) entao
Y[k] <- V[i]
k <- k+1
fimse
fimpara
escreval("Vetor Y compactado")
para i de 1 ate k-1 faca
escreval (y[i])
fimpara

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores


Número de Mensagens: 126
Data de inscrição: 26/10/2007

MensagemAssunto: Re: Vetor compactado 2   Qui Nov 15, 2007 4:03 pm

Pelo que eu entendi... Um vetor lê os números o outro tira os números repetidos, se for, isso está correto.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
 

Vetor compactado 2

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

 Tópicos similares

-
» [Vetor] Retro Stars
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Vetor X Pixel Art
» Meu vetor - Desenho
» Dúvida Vetor

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster ::  ::  :: -