VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Multiplicar Diagonal Principal da Matriz

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Multiplicar Diagonal Principal da Matriz   Seg Nov 12, 2007 6:14 pm

Faça um algoritmo/programa que receba uma matriz A(6,6)
e retorne a média aritmética dos elementos abaixo da diagonal principal.

Eu não sei como calcular a media dos elementos abaixo da Diagonal Principal da Matriz.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Seg Nov 12, 2007 7:23 pm

Bom continuo com a mesma dúvida... "diagonal principal" pode ser interpretada de diversas formas, pergunte ao seu professor o que é essa diagonal.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Ter Nov 13, 2007 2:25 pm

Bem Diagonal principal pelo que eu entendo e assim

1 3 2
1 3 2
1 3 2

DP 1, 3 e 2

O algoritmo quer a media dos elementos abaixo da DP
Ou seja 1 + 1 + 3 / 3 = 5/3

E diagonal principal e quando i=j

Só não sei passar isto para algoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Qui Nov 15, 2007 1:23 pm

Cara, você tem que procurar algum comportamento em comum nos elementos com o qual deseja trabalhar.
Observe essa matriz de ordem 3x3:

a11 a12 a13
a21 a22 a23
a31 a32 a33

elementos acima da diagonal principal --> a12; a13; a23 (i < j)
elementos da diagonal principal --> a11; a22; a33 (i = j)
elementos abaixo da diagonal principal --> a21; a31; a32 (i > j)

Se você observou, os elementos abaixo da diagonal principal têm uma caracterista em comum, essa caracteristica é que nesses elementos i sempre é maior que j.

A partir desta caracteristica você pode usar a estrutura de repetição "para" juntamente com um "se" para testar quais os elementos de sua matriz satisfazem essa condição.
Aqueles elementos que satisfazerem tal condição você os soma. Será necessário o uso de um contador, para guardar o número de elementos somados e depois você poder tirar a média dos elementos.

Lembrando que como você está trabalhando com matriz serão necessários o uso de dois "para". Somente assim você poderá testar todos os elementos da matriz.

Ex:

Para i de 1 ate n faca //n representa a ordem da matriz
Para j de 1 ate n faca
Se (i > j) entao
soma <- soma + matriz[i,j]
contador <- contador + 1
Fimse
Fimpara
Fimpara

Espero ter ajudado =)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Qui Nov 15, 2007 1:30 pm

Não sei se o que fiz ai em cima é permitido no forum, me refiro ao trecho do algoritmo que postei. Sou novo no forum, caso não seja permitido por favor retirem.

=)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Qui Nov 15, 2007 3:19 pm

Problema quase resolvido
Vou tentar fazer o algoritmo para depois dizer se funcionou ou não
Administradores favor não trancar este tópico
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Qui Nov 15, 2007 5:01 pm

Tudo que é ou não é permitido no fórum ta na seção de regras, isso ai é permitido sim. O que não é permitido aqui é passara algoritmos prontos, apenas a lógica, a propósito muito boa sua explicação.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Qui Nov 15, 2007 5:58 pm

=) OK, muito obrigado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Sex Nov 16, 2007 11:13 am

Acho que eu consegui fazer
Pode conferir se esta certo?
Se estiver pode trancar o tópico

algoritmo "Media elementos"
//Função: Faça um algoritmo/programa que receba uma matriz A(6,6)
//e retorne a média aritmética dos elementos abaixo da diagonal principal.
// Data : 30/10/07
// Seção de Declarações
var
matA, matB : vetor [1..6,1..6] de real
i, j: inteiro //os índice sempre inteiro
s, c : real
ma : real
inicio
// Seção de Comandos
c <- 0
s <- 0
Para i de 1 ate 6 faca
Para j de 1 ate 6 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matA[i,j])

Se (i > j) entao
s <- s + matA[i,j]
c <- c + 1
fimse

fimpara
fimpara
escreval
ma <- s/c

escreva("A matriz A é:")
escreval
para i de 1 ate 6 faca
escreval
para j de 1 ate 6 faca
escreva (matA[i,j]," ")
fimpara
fimpara
escreval
escreval("Amedia dos elemntos abiaxo da diagonal principal eh =",ma)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Sex Nov 16, 2007 1:39 pm

Isso guga, pelo jeito esta tudo certinho sim.
Para ter certeza que esta certo teste com valores aleatorios.. =)

So nao intendi uma coisas.. por que vc declarou duas matrizes??

matA esta correto, voce faz uso dela no algoritmo.
e matB, fica onde?? caso nao use ela no algoritmo tira ela das declaracoes para poupar memoria. =)

num algoritmo pequeno essa quantidade de memoria nao faz diferenca, mas quando for trabalhar um programas maiores esse memoria podera fazer falta.

abracos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Sab Nov 17, 2007 9:26 am

Rodou legal
Obrigado
Administradores podem trancar o tópico
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Sab Nov 17, 2007 1:48 pm

Boa guga..
o que voce fez com a matriz B??

abracos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Sab Nov 17, 2007 2:57 pm

Não tem matrizB
Eu esqueci de apagar a variavel.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   Sab Nov 17, 2007 3:01 pm

Isso ai.. =) era isso mesmo, ela estava declarada, mas nao estava sendo usada no algoritmo.

Por isso a pergunta.

abraços.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Multiplicar Diagonal Principal da Matriz   

Voltar ao Topo Ir em baixo
 
Multiplicar Diagonal Principal da Matriz
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Aula] Array e Matriz em GML
» Efeito na diagonal em todas as imagens do perfil
» VPN PPTP com 1 matriz e 2 filial ?
» Multiplicar o widget de votação
» Multiplicar widget de votação

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: