VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Vetor troca

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Vetor troca   Seg Nov 12, 2007 6:19 pm

Escrever um algoritmo que lê um vetor K(20) e o escreve. Troque, a seguir, os elementos de ordem ímpar com os de ordem par imediatamente seguintes e escreva o vetor k modificado.

Eu fiz só que o algoritmo me apresenta 0 nos elementos impares
Onde esta o erro?

//Prenchimento do vetor K
Para i de 1 ate 20 faca
escreva("Digite um valor do elemento da linha" , i,"do vetor K: ")
leia (K[i])

//Aqui e para trocar os elementos
para i de 1 ate 20 passo 2 faca
aux <- k[i]
k[i] <- k[i+1]
k[i+1] <- aux
fimpara

fimpara
//Final do algoritmo mostrando o vetor K modificado
escreva("K ")
escreval
para i de 1 ate 20 faca
escreval (k[i]," ")
fimpara
escreval
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Vetor troca   Qua Nov 14, 2007 10:01 am

Consegui fazer
Ola aqui o código
Pode trancar o tópico

para i de 1 ate 19 passo 2 faca
aux <- k[i]
k[i] <- k[i+1]
k[i+1] <- aux
fimpara

escreva("K ")
escreval
para i de 1 ate 20 faca
escreval (k[i]," ")
fimpara
escreval
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Vetor troca
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Engine]troca de personagens durante o jogo
» Não está habilitada a troca de rank do usuario
» Jogos de ps3 e xbox 360 troca ou venda.

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: