VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Mostrar elemntos pares na Matriz B

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Mostrar elemntos pares na Matriz B   Seg Nov 12, 2007 6:42 pm

Fazer um algoritmo que:
1º Coluna da Matriz calcula o elemento + 1
2º Coluna da Matriz calcula o elemento elevado a linha
3º Coluna da Matriz calcula o fatorial
Depois o algoritmo me mostra a soma dos elementos pares na Matriz B
Mais ai que esta o erro me retorna só zero
E eu fui ageitar o algoritmo e acabei fazendo mais besteira ainda que agora o algoritmo não roda mais.
Vocês poderiam ajeitar ele para mim?

algoritmo "matriz e vetor"
// Função : Mostraz Matriz através de vetor
// Autor : Gustavo Rodrigues Torre
// Data : 31/10/2007
// Seção de Declarações
var
A: vetor[1..5] de inteiro
B : vetor[1..5,1..3] de inteiro
i,j,p,s,col2 : inteiro
fat : inteiro
inicio
// Seção de Comandos
repita
limpatela
Para i de 1 ate 5 faca
escreva("Digite um valor do elemento da linha" , i, "do vetor A: ")
leia (A[i])
B[i,1] <- A[i] + i
col2 <- 1
para s de 1 ate i faca
col2 <- col2 * A[i]
fimpara
B[i,2] <- A[i] ^ i

fat<-1

para j de 1 ate A[i] faca
fat <- fat * j
fimpara
B[i,3] <- fat
fimpara
escreval
escreval(" Vetor A Matriz B: ")
escreval

s <- 0

para i de 1 ate 5 faca
escreva(A[i]," ")
para j de 1 ate 3 faca
escreva (B[i,j]," ")
se (B[i,j] mod 2 = 0 ) entao
s <- s + 1
fimse
fimpara
escreval
fimpara
escreval
escreval("A matriz B tem ",s," elemento(s) par(es)")
escreval("deseja continuar (1)Sim (0)Não")
leia(p)
ate(p=0)
escreval

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Mostrar elemntos pares na Matriz B   Qui Nov 15, 2007 8:02 pm

Guga, vou tentar ajudar nesse topico no que eu puder.

--Primeiro voce deve gerar a matriz. Sera necessario entao o uso de dois "para" de 1 ate n, onde n e a ordem da matriz.

ex:

para i de 1 ate n faca
para j de 1 ate n faca
leia (matA[i,j])
fimpara
fimpara

--para somar os elementos + 1 voce pode usar o mesmo "para", ficando assim:

para i de 1 ate n faca
para j de 1 ate n faca
leia (matA[i,j])
matB[i,j] <- matA[i,j] + 1
fimpara
fimpara

ou se preferir usar outro, ficando assim:

para i de 1 ate n faca
para j de 1 ate n faca
leia (matA[i,j])
fimpara
fimpara

para i de 1 ate n faca
para j de 1 ate n faca
matB[i,j] <- matA[i,j] + 1
fimpara
fimpara

--Para calcular o elemento elevado a linha, basta fazer o seguinte comando para todos os elementos da matriz:

matB[i,j] ^ i

OBS: Se voce estudar o comportamento do algoritmo podera perceber que neste caso, i representa as linhas e j as colunas.

--A questao do fatorial ainda estou em duvida da melhor maneira de fazer. Vou dar uma olhada melhor e posto aqui ok??
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Mostrar elemntos pares na Matriz B   Sex Nov 16, 2007 11:08 am

Ta vou esperar
Olha esse mesmo tópico no suporte pq eu postei ele lá tb
Abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Mostrar elemntos pares na Matriz B   Qua Nov 21, 2007 12:45 pm

Tópico abandonado.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Mostrar elemntos pares na Matriz B   

Voltar ao Topo Ir em baixo
 
Mostrar elemntos pares na Matriz B
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Aula] Array e Matriz em GML
» Mostrar quem está lendo o topico
» Mostrar quem está lendo o tópico
» Mostrar link de meu fórum ao copiarem conteúdo.
» Código para mostrar texto completo

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: