VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Repetição

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
Ir à página : Anterior  1, 2
AutorMensagem
Thiago
Novato
Novato
avatar

Masculino
Número de Mensagens : 13
Idade : 33
Localização : minas gerais
Data de inscrição : 10/11/2007

MensagemAssunto: Re: Repetição   Qua Nov 21, 2007 2:52 pm

Use este,

algoritmo "semnome"
var
n,j,c,n1,n2,d:inteiro
media,aux:real
inicio
leia(n1,n2)
se n1<n2 entao
para c de n1 ate n2 faca
n<- n+n1+n2
d<- d+2
fimpara
c<- c-1
media<- n/d
escreval("A média dos valores é :",media)
fimse
se n1 > n2 entao
para c de n2 ate n1 faca
aux<- aux + 1
fimpara
se (n1 mod 2 =0)e(n2 mod 2=0) entao
aux<- aux/2 + 0.5
senao
se (n1 mod 2 <>0)e(n2 mod 2<>0) entao
aux<- aux/2 - 0.5
senao
se (n1 mod 2 = 0)e(n2 mod 2<>0) ou (n1 mod 2 <>0)e(n2 mod 2 = 0)entao
aux<- aux/2
fimse
fimse
fimse
fimse
escreval("A quantidade de pares é :",aux)
fimalgoritmo

Admins. se vc pegar uma sequencia de números tipo:
1 2 3 4 5, ele começa com impar e termina com impar, se eu dividir a qtde de elementos q tem por dois e subtrair de meio, acho a quantidade de numeros pares, se a questão eh achar soh a qtde de pares, economizo em tempo de resposta, dependendo do intervalo q for digitado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Repetição   Qua Nov 21, 2007 5:43 pm

Continua mostrando 0 nos numeros pares
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Repetição   Qua Nov 21, 2007 10:55 pm

Guga, voce esta fazendo algumas confusoes, primeiro leia o problema e identifica o q ele pede e o que voce ira precisar para cada situacao

-Para um intervalo crescente ele pede a media dos numeros do intevalo, incluindo os numeros digitados

O que voce ira precisa?
--> um acumulador
--> um contador

-Para um intervalo decrescente ele pede a quantidade de numeros pares do intervalo, incluindo os numeros digitados

O que voce ira precisa?
--> Uma variavel auxiliar, para guarda o resto da divisao inteira;
--> um contador

-Se nao houver intervalo, exibit a mensagem numeros iguais.

O que voce ira precisa?
--> Nada =)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Repetição   Qua Nov 21, 2007 11:17 pm

--> Como identificar se o intervalor e crescente ou decrescente?

Simples, verifique se num2 - num1 e maior ou menor que zero,

+ se for maior significa que forma um intevalo crescente
+ se for menor significa que forma um intervalo decrescente
+ se for igual a zero significa que os numero sao iguais

------------------------------------------------
Identificou um intervalo crescente, o que fazer?

+ use um acumulador para guardar a soma de todos os elementos de num1 ate num2;
+ use um contador para guardar a quantidade de elementos somados;
------------------------------------------------
Identificou um intervalo decrescente, o que fazer?

+ teste cada elemento da matriz, de num2 ate num1;
+ use um contador para guarda a quantidade de elementos pares (dica: voce pode usar o mesmo contador para os dois casos pois apenas uma das condicoes sera verdadeira)

Eu fiz esse algoritmo aqui, qualquer coisa posto ele depois. Abracos
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Repetição   Qui Nov 22, 2007 11:28 am

Vou tentar fazer aqui
Depois eu posto
E eu consegui aprovação hoje na matéria de algoritmos mais vou continuar postando aqui
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Repetição   

Voltar ao Topo Ir em baixo
 
Repetição
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 2 de 2Ir à página : Anterior  1, 2
 Tópicos similares
-
» Remover repetição da imagem de fundo
» comando ou formula para evitar repetição de nomes
» Fixar fundo sem repetições independente da resolução
» Fundo do fórum sem repetição (no-repeat)
» Repetição de uma palavra no campo de perfil

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: