VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Produto pares

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Produto pares   Qua Nov 14, 2007 7:58 pm

Como postado anteriormente eu não consegui fazer o algortimo multiplicar os elementos pares
Onde esta o erro?

algoritmo "produto pares"
// Função :
// Autor : Gustavo Rodirgues Torre
// Data : 27/10/07
// Seção de Declarações
var
n : inteiro
a : inteiro
p : inteiro
inicio
// Seção de Comandos
p <- 1
a <- 1
enquanto (p<=1) faca
repita
escreva ("Entre com valores: ")
leia(n)
para a de 0 ate n faca

se (a%2=0) entao
a <- a * n
fimse

fimpara

ate (n=0)
escreval("O produto dos pares eh ",a)
escreval("Deseja continuar? (1)Sim (2)Não")
leia(p)
limpatela
fimenquanto

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Produto pares   Qui Nov 15, 2007 3:17 pm

Problema resolvido pode trancar o tópico

algoritmo "produto pares"
// Função :
// Autor : Gustavo Rodirgues Torre
// Data : 27/10/07
// Seção de Declarações
var
n : inteiro
acm : inteiro
a : inteiro
p : inteiro
inicio
// Seção de Comandos
p <- 1
a <- 1

escreva ("Entre com valores: ")
leia(n)

enquanto (n<>0) faca

se (n MOD 2=0) entao
a <- a * n
fimse

escreva ("Entre com valores: ")
leia(n)

fimenquanto

escreval("O produto dos pares eh ",a)
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Produto pares
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Qual será este produto?
» Historico do Produto
» Lente Que Aumenta Os Olhos Vira Febre Nos EUA
» como ligar switch no poste usando fio de telefone
» Ultrabook híbrido Taichi 21: Conheça este interessante produto da ASUS

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: