VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 CORREÇAO

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
brmarcus
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 27
Localização : fabriciano
Data de inscrição : 14/11/2007

MensagemAssunto: CORREÇAO   Qua Nov 14, 2007 10:28 pm

TE COMO CORRIGIR ESSE ALGORITMO...TIPO EU QUERO FAZER UMA BUSCA NO MEU ALGORITMO. QUANDO ALGUEMA XEGAR NA LOCADORA E PROCURAR POR UM FILME POR UM TITULO, GENERO, DIRETOR, CODIGO. NAO TO CONSEGUINDO FAZER ISSO...


algoritmo "Marcus Vinícius de Almeida Camilo"
// Função : LOCADORA
// Autor :
// Data : 14/11/2007
// Seção de Declarações
funcao buscafilmet( ):inteiro
var
titulo:caracter
i,achei:caracter

inicio
leia (titulo)
se (titulo = cat1[i,1]) entao
achei<-i
fimpara
retorne(achei)
fimfuncao

inicio
para i de 1 ate 5 faca
escreval ("Titulo")
leia (cat1[i,1])
escreval
escreval("Diretor")
leia (cat1[i,2])
escreval
escreval ("Genero")
leia (cat1[i,3])
escreval
escreval ("Código")
leia (cat2[i])
escreval("_____________________________________________________________")
fimpara
escreval ("Escolha uma opção")
escreval ( "Digite 1 para buscar filme por titulo")
escreval ( "Digite 2 para buscar filme por diretor")
escreval ( "Digite 3 para buscar filme por genero")
escreval ( "Digite 4 para buscar filme por codigo do filme na locadora")

escreval("digite o numero da busca")
leia (x)
se (x<0) entao
se (x>4)entao
leia (x)
fimse
fimse
escolha x
caso 1
titulo
se (cat1[1,2])entao

caso 2
diretor
caso 3
genero
caso 4
codigo





fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
CORREÇAO
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Cirurgia para correção de miopia e astigmatismo
» Colocar corretor ortográfico
» Várias dúvidas sobre correção de espaços etc no layout
» Mikrotik Version 5.14 (Stable) (Correção)
» Correção no código CSS do fórum

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: