VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Media numeros pares

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Media numeros pares   Qui Nov 15, 2007 4:02 pm

Estou com um problema em calcular a média dos numeros pares
Este algoritmo deveria calcular a média de todos os numeros que forem pares

algoritmo "media pares"
// Função : . Escreva um algoritmo/programa que calcule a média de uma seqüência
//de números digitados pelo usuário, se eles forem pares.
//Termine a leitura se o usuário digitar zero (0).
// Autor : Gustavo Rodrigues Torre
// Data : 4/10/2007
// Seção de Declarações
var
n : inteiro
acm : real
inicio
// Seção de Comandos
repita
escreva("Digite um valor: ")
leia(n)
se (acm>=0) entao
se (n%2=0) entao
se (n<>0) entao
acm <- (acm + n) / acm
fimse
fimse

ate(n=0)

escreva(acm)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Media numeros pares   Qui Nov 15, 2007 4:50 pm

Primeiro:
O conceito de média aritmética consiste em:
Somar "X" números e dividir por "X", ex:
4 + 4 + 4 + 4 + 4 : 20
Temos um total de 5 algarismos, então : 20 / 5 = 4, onde 4 é a média.
Baseado neste conceito vemos que
acm <- (acm + n) / acm está errado.
Você tem que criar uma nova variáve para acumular quantos números pares existem, e dividir a soma por ela, mas lembre-se, se você colocar a divisião dentro do loop, ele irá dividir até que a condição do loop seja verdadeira.

Mais uma coisa, substitua o "Repita" por um "Enquanto" com a condição necessária.

Lembre-se, uma variável deverá receber o valor da soma de números pares dividida pela soma da quantidade números pares. Essa conta nem sempre será exata.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Media numeros pares   Qui Nov 15, 2007 7:39 pm

--> Amigo, use um enquanto (n<>0) faca ... Desta forma o loop so ira terminar quando o usuario digitar 0

--> crie uma variavel para receber os valores digitados pelo usuario, por exemplo num

--> use outra variavel para acumular os valores pares somados.
Lembre-se que para um numero ser par o resto de sua divisao deve ser igual a 0 (divisao inteira). para divisao inteira temos os operadores (MOD ou %). Ex: 5 MOD 2 = 1

--> sera necessario tambem o uso de um contador, para guardar quantos numeros pares foram digitados pelo usuario

a partir dessa ideia voce pode por dentro do enquanto uma condicao para somar somente os numeros pares.

Ex:

num <- -1 //inicia variavel num com um valor qualquer, diferente de zero, para poder ser testada no enquanto e dar inicio ao loop
somatorio <- 0
contador <- 0
enquanto (num<>0) faca
limpatela
escreva ("Digite o valor desejado:")
leia (num)
aux <- (num MOD 2) //divisao inteira de num por 2
se (num<>0) entao
se (aux = 0) entao //se aux=0 significa que e par
somatorio <- somatorio + num
contador <- contador + 1
fimse
fimse
fimenquanto
limpatela


OBS: o trecho "Se (num<>0) entao" e necessario, pois caso nao tenha o contador ira contar um numero mais, ja que 0 mod 0 igual a 0, satisfazendo a condicao imposta, resultando assim um erro quando for calcular a media.

-- Para calcular a media basta dividir o somatorio pela quantidade de numeros pares digitados pelo usuario, neste caso o contador.

espero ter ajudado =)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Media numeros pares   Sex Nov 16, 2007 11:39 am

Eu fiz como vc falou
O algoritmo e este que vc mandou?
Se for esta funcionando perfeitamente
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Media numeros pares   Sex Nov 16, 2007 1:52 pm

Sim, esse que mandei e parte do algoritmo..
Falta colocar os comandos para calcular a media dos numeros pares, no caso esses comandos podem ser colocados apos o "fimenquanto". Ex:

media <- somatorio/contador
escreva ("A média é:", media)

Voce conseguiu intender a logica do algoritmo??
Conseguiu ver que a condicao "Se (num<>0) entao" e realmente necessaria nesse algoritmo?? Caso contrario o contador contara um numero a mais, resultando erro ao calcular a media?

Abracos
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Media numeros pares   Seg Nov 19, 2007 8:30 am

Eu entendi sim
E vou colocar o calculo da media fora do laço

Abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Media numeros pares   Seg Nov 19, 2007 8:30 am

Problema resolvido
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Media numeros pares   

Voltar ao Topo Ir em baixo
 
Media numeros pares
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Go Media Arsenal - Complete Photoshop Brush Sets 1-14
» Expandir o Game Maker com essa LIB de media player
» modificar pontuaçao rank numeros para rank nomes
» Como escureçer os Nomes e Numeros Do Fórum
» Colocar media player

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: