VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Media matriz

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Media matriz   Sex Nov 16, 2007 11:15 am

Faça um algoritmo que receba uma matriz A(4,4)e retorne a soma dos elementos acima da diagonal principal.

Eu não sei se esta correto o que eu fiz

algoritmo "Soma elementos"
//Função:
// Data : 30/10/07
// Seção de Declarações
var
matA, matB : vetor [1..4,1..4] de real
i, j: inteiro //os índice sempre inteiro
s : real
inicio
// Seção de Comandos
s <- 0
Para i de 1 ate 4 faca
Para j de 1 ate 4 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matA[i,j])

se (i < j) entao
s <- s + matA[i,j]
fimse

fimpara
fimpara
escreval

escreva("A matriz A é:")
escreval
para i de 1 ate 4 faca
escreval
para j de 1 ate 4 faca
escreva (matA[i,j]," ")
fimpara
fimpara
escreval
escreval("A soma dos elementos acima da diagonal principal = ",s)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Media matriz   Sex Nov 16, 2007 1:44 pm

Guga, esse algoritmo e quase o mesmo do outro post seu, a respeito da media dos elementos abaixo da diagonal principal.

Neste caso, i < j como voce pode observar. =)
Nao e necessario tambem o uso de um contador, ja que neste caso o objetivo e obter apenas a soma dos elementos acima da diagonal principal.

Vou fazer a mesma pergunta que fiz no outro post. Para que server essa matB?? declarada nas variaves..

Se nao vai fazer o uso dela retire ela para poupar memoria.

--Pelo que pude observar o algoritmo esta certo sim, teste ele com valores aleatorios para ter total certeza.

abracos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Media matriz   Sab Nov 17, 2007 9:24 am

Rodeou perfeitamente
Administradores podem trancar o tópico
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Media matriz   Sab Nov 17, 2007 1:47 pm

Boa guga... =)
abracos..
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Media matriz   Seg Nov 19, 2007 8:31 am

Administradores podem trancar o tópico
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Media matriz   

Voltar ao Topo Ir em baixo
 
Media matriz
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Go Media Arsenal - Complete Photoshop Brush Sets 1-14
» [Aula] Array e Matriz em GML
» Expandir o Game Maker com essa LIB de media player
» Colocar media player
» VPN PPTP com 1 matriz e 2 filial ?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: