VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Menor valor da Matriz

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Menor valor da Matriz   Sab Nov 17, 2007 9:39 am

Faça um algoritmo que receba uma matriz A(5,5) e retorne o menor valor dos elementos abaixo da diagonal secundária.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Menor valor da Matriz   Sab Nov 17, 2007 1:54 pm

Guga, o que voce ja fez??
Vou dar algumas dicas ok?

--Primeiro, gere a matriz na qual que encontrar o menor elemento

--Segundo, voce precisara de uma variavel para guarda o valor do menor elemento. Apos ter gerado a matriz e criado a variavel faca ela receber o valor de elemento A11, desta forma voce podera iniciar os testes.

--A partir dai e so testar todos os elementos um com os outros, e sempre que acha um valor menor guarda esse valor na variavel criada. =)

abracos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Menor valor da Matriz   Sab Nov 17, 2007 2:56 pm

Este algoritmo eu ainda não gerei a matriz mais isso e fácil
Agora como vc falou vou criar uma variavél para achar guardar o menor valor
Depois eu posto aqui para vc ver como ficou.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Menor valor da Matriz   Sab Nov 17, 2007 3:03 pm

Faz assim oh, faz a variavel menor receber, a priori, o valor do elemento A[1,1].. Depois voce compara o valor da variavel menor com os demais elementos da matriz.. Sempre que achar um valor menor substitui.

abracos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Menor valor da Matriz   Seg Nov 19, 2007 8:28 am

Vou tentar fazer se não der certo eu posto aqui.
Abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Menor valor da Matriz   Qua Nov 21, 2007 10:48 am

Acho que consegui resolver
Olha aqui

algoritmo "Menor valor DS "
//Função:
// Data : 21/11/07
// Seção de Declarações
var
matA : vetor [1..5,1..5] de real
i, j : inteiro //os índice sempre inteiro
menor : real
inicio
// Seção de Comandos
menor <- 100
Para i de 1 ate 5 faca
Para j de 1 ate 5 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matA[i,j])

se (i+j > 6) entao
se (matA[i,j] < menor) entao
//modificando o valor de menor
menor <- matA[i,j]
fimse
fimse
fimpara
fimpara
escreval


escreva("A matriz A é:")
escreval
para i de 1 ate 5 faca
escreval
para j de 1 ate 5 faca
escreva (matA[i,j]," ")
fimpara
fimpara
escreval
escreval("O menor valor abaixo da diagonal secundária e = ",menor)
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Menor valor da Matriz   Qua Nov 21, 2007 10:32 pm

Guga, nao conseguii intender a logica de seu algoritmo.. ??

por a condicao i+j > 6 ?? Para testar o que? Nao vii nada no enunciado do problema que leve a usar essa condicao. Preste atencao, o problema quer que o algoritmo encontre o menor valor pra matriz, isso e simples:

--primeiro, faca o uso de dois "para" para fazer a leitura da matriz

-segundo, apos feito o passo acima faca a variavel menor receber o valor A[1,1] (apenas a priori)

--terceiro, apos a variavel menor receber o valor A[1,1] faca novamente o uso de dois "para", agora testando se o elemento em questao e menor que o valor da variavel menor, ou seja:

se (A[i,j] < menor) entao
menor <- A[i,j]
fimse

Viu?? Como disse antes, a variavel menor recebe o valor A[1,1] no inicio apenas a priori, caso haja algum elemento na matriz menor que o valor A[1,1] a variavel menor ira receber seu valor quando for feito o teste em tal variavel. O algoritmo ira trabalhar da seguinte maneira:

--Fara a leitura de todos os elementos da matriz;
--a variavel menor ira receber o valor de A[1,1];
--Sera feito o teste com todos os elementos da matriz para verificar se existe algum valor menor, caso exista, esse valor sera colocado na variavel menor.

Imagine, que ao terminar a leitura temos a seguinte matriz:

3 8 9 7 4
4 2 5 4 4
5 6 7 8 9
9 8 7 6 1

O que ira ocorrer?

-- A variavel menor ira receber o valor 3: menor <- 3
-- Sabemos que esse nao e o menor valor da matriz, mas observe que quando o algoritmo fizer o teste para o elemento A[2,2], a variavel menor receber o valor de A[2,2], ja que A[2,2] = 2 e 2<3. Lembra-se da condicao?

Se (A[i,j] < menor) entao
menor <- A[i,j]
fimse

--ok, esse ainda nao é o menor valor da matriz, mas observe que o algoritmo continuara testando e comparando o valor da variavel menor com os demais elementos da matriz ate chegar ao ultimo elemento, ou seja, toda vez que o algoritmo encontrar um elemento que satisfaca a condicao A[i,j] < menor ele executara o comando menor <- A[i,j].

--E o que ira acontecer com a matriz usada com exemplo acima, o elemento A[4,4] satisfaz a condicao imposta no algoritmo, logo o comando menor <- A[4,4] sera executado. =)

espero ter ajudado
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Menor valor da Matriz   Qui Nov 22, 2007 11:30 am

Teste agora e verifique
Eu fiz este algoritmo hoje na minha prova e acertei.

Abraços

algoritmo "Menor valor DS "
//Função:
// Data : 21/11/07
// Seção de Declarações
var
matA : vetor [1..5,1..5] de real
i, j : inteiro //os índice sempre inteiro
menor : real
inicio
// Seção de Comandos
menor <- 100
Para i de 1 ate 5 faca
Para j de 1 ate 5 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matA[i,j])

se (i+j > 4) entao
se (matA[i,j] < menor) entao
//modificando o valor de menor
menor <- matA[i,j]
fimse
fimse
fimpara
fimpara
escreval

escreva("A matriz A é:")
escreval
para i de 1 ate 5 faca
escreval
para j de 1 ate 5 faca
escreva (matA[i,j]," ")
fimpara
fimpara
escreval
escreval("O menor valor abaixo da diagonal secundária e = ",menor)
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Menor valor da Matriz   Qui Nov 22, 2007 4:19 pm

Então tópico trancado

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Menor valor da Matriz   

Voltar ao Topo Ir em baixo
 
Menor valor da Matriz
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvidos]Maior e menor valor na consulta
» Somar valores indiretos e descartar o menor valor "access"
» numa consulta obter menor valor de várias colunas
» [Aula] Array e Matriz em GML
» Colocar valor mínimo no lançamento de dados

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: