VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Elementos repetidos na Matriz

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Elementos repetidos na Matriz   Sab Nov 17, 2007 3:02 pm

Escrever um algoritmo que lê uma matriz N(5,5) e a escreve. Verifique, a seguir, quais os elementos de M que estão repetidos e quantas vezes cada um deles está repetido. Escrever cada elemento repetido com uma mensagem dizendo a quantidade de vezes que aparece M.

Eu fiz mas não estou conseguindo "Escrever cada elemento repetido com uma mensagem dizendo a quantidade de vezes que aparece M"

algoritmo "Verificar numeros repetidos"
//Função:
// Data : 17/11/07
// Seção de Declarações
var
matA : vetor [1..5,1..5] de real
i, j: inteiro //os índice sempre inteiro
iguais,c : real
//c: Contagem dos elementos repetidos na Matris
//iguais: mostra quantidade de elementos repetidos
inicio
// Seção de Comandos
c <- 0 //Contador de elementos repetidos na Matris
iguais <- 0 //mostra quantidade de elementos repetidos

Para i de 1 ate 5 faca
Para j de 1 ate 5 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matA[i,j])

c <- c + matA[i,j]
iguais <- iguais + 1

fimpara
fimpara
escreval

escreva("A matriz A é:")
escreval
para i de 1 ate 5 faca
escreval
para j de 1 ate 5 faca
escreva (matA[i,j]," ")
fimpara
fimpara
escreval
escreval("A media dos elementos acima da diagonal secundaria eh =",c)
escreval("A quantidade de elementos repetidos na matriz =",iguais)


fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Ter Nov 20, 2007 9:02 pm

guga22 escreveu:

c <- 0 //Contador de elementos repetidos na Matris
iguais <- 0 //mostra quantidade de elementos repetidos

Ambos tem a mesma função?

guga22 escreveu:

c <- c + matA[i,j]
iguais <- iguais + 1

iguais <- iguais + 1
Você não criou nenhuma condição.[

c <- c + matA[i,j]
Se você precisa saber qual o número está sendo repetido, e não a soma deles, isso está errado.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 9:35 am

Então como eu faço?
Eu preciso usar um se?

Ou preciso criar mais uma variavel porque o algoritmo me pede
"Escrever cada elemento repetido com uma mensagem dizendo a quantidade de vezes que aparece em N"
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 11:32 am

Sim você tem que usar um "se" para fazer uma condição, porque isso
iguais <- iguais + 1
só deveria acontecer quando os números forem iguais, e não a cada loop.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 11:35 am

Mais onde eu colocaria este se?

E com qual condição?

Se eu colocar matA[i,j] = i,j da erro

algoritmo "Verificar numeros repetidos"
//Função:
// Data : 17/11/07
// Seção de Declarações
var
matA : vetor [1..5,1..5] de real
i, j: inteiro //os índice sempre inteiro
iguais,c : real
//c: Contagem dos elementos repetidos na Matris
//iguais: mostra quantidade de elementos repetidos
inicio
// Seção de Comandos
c <- 0 //Contador de elementos repetidos na Matris
iguais <- 0 //mostra quantidade de elementos repetidos

Para i de 1 ate 5 faca
Para j de 1 ate 5 faca
escreva("Digite um valor do elemento da linha" , i, ", coluna ",j, " da matriz A: ")
leia (matA[i,j])

fimpara
fimpara
escreval

escreva("A matriz A é:")
escreval
para i de 1 ate 5 faca
escreval
para j de 1 ate 5 faca
escreva (matA[i,j]," ")
fimpara
fimpara
escreval
escreval("A media dos elementos acima da diagonal secundaria eh =",c)
escreval("A quantidade de elementos repetidos na matriz =",iguais)


fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 11:39 am

Pense:
Se você tem que verificar se existe um número igual ao outro, você tem que verificar e depois fazer uma condição, ex:
se numero = numero 2

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 11:39 am

Pense:
Se você tem que verificar se existe um número igual ao outro, você tem que verificar e depois fazer uma condição, ex:
se numero = numero 2

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 11:40 am

E no caso da matriz eu preciso verificar se um elemento e igual ao outro mais eu ainda não consegui visualizar a solução para isso
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 11:54 am

Eu poderia fazer assim?
Usando um acm para guardar os valores repetidos?
E como eu faço para o algoritmo me dizer qual numero esta sendo repetedido e quantas vezes?


se (matA[i,j]=j) entao
acm <- 1 + matA[i,j]
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 12:03 pm

Comparar elementos numa matriz exige uma estrutura de nível de dificuldade relativamente alto.
Não há muitas formas de se explicar muito o que há de ser feito sem passar o código literalmente.

Vou passar uma breve explicação do que deve ser feito:

Depois que o usuário digitar cada valor da matriz, você deve usar uma estrutura parecida com a que você usou na exibição da matriz, porém, ao invés de exibir os valores da matriz, você terá que fazer um 'Se' para comparar esse elemento da matriz com todos os outros elementos seguintes. Para isso você pode precisar de mais 'paras', e não acredito que seja algo que se possa montar sem diversas tentativas anteriores.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 12:14 pm

Então esta explicado este algoritmo e de dificil solução
Mais então eu vou precisar de muitos paras
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 12:44 pm

Precisa de muitos paras, muita paciência, e muita atenção.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Elementos repetidos na Matriz   Qua Nov 21, 2007 5:46 pm

Então pode trancar o tópico
Obrigado pela ajuda
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Elementos repetidos na Matriz   

Voltar ao Topo Ir em baixo
 
Elementos repetidos na Matriz
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Aula] Array e Matriz em GML
» Usuários com nomes repetidos
» VPN PPTP com 1 matriz e 2 filial ?
» Como personalizar a parte do portal e tirando alguns menu repetidos
» Mudar posição de alguns elementos

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: