VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Por em ordem crescente e descrecente

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
ANDERSON
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 30
Localização : Brasil
Data de inscrição : 10/11/2007

MensagemAssunto: Por em ordem crescente e descrecente   Dom Nov 18, 2007 12:57 pm

Crie um algoritmo que leia 5 números distintos e os ordene crescente e descrecentemente. Question

sem usar loping
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Dom Nov 18, 2007 1:12 pm

O amigo, o looping é apenas um comando usado para facilitar a vida do programador, nada impede que os comandos sejam feitos passo a passo.

Imagine o comando
para i de 1 ate 5
leia (vetor[i])
fimpara

O que o algoritmo fara sera o seguinte:

i <- 1
leia (vetor[i])
i <- i + 1
leia (vetor[i])
i <- i + 1
leia (vetor[i])
i <- i + 1
leia (vetor[i])
i <- i + 1
leia (vetor[i])

--Viu? Se voce quer uma algoritmo que nao use looping e que coloque em ordem crescente e decrescente 5 numeros digitados pelo usuario tente fazer o mesmo que eu fiz acima com algum algoritmo de ordenacao de vetor. Sugiro o algoritmo de ordenacao conhecido como "metodo da bolha". =)

-->Para fazer a ordenacao crescente e decrescente basta repetir os comandos trocando a condicao =)

--> esperto ter ajudado.

abracos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ANDERSON
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 30
Localização : Brasil
Data de inscrição : 10/11/2007

MensagemAssunto: Comando de Desvio Condicional e Comando de Seleção Múltipla   Dom Nov 18, 2007 1:22 pm

tou no começo do curso so tive aula de Comando de Desvio Condicional e Comando de Seleção Múltipla são as únicas ferramentas que eu posso usar, se colocar algo além o prof. n vai aceitar...

obrigado
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Seg Nov 19, 2007 2:04 pm

Quando fizer posta aqui pra a gent ver o resultado =)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Seg Nov 19, 2007 4:08 pm

Oi galera, estive viajando nesse feriado prolongado, mas já estou de volta, gfilho, agradeço muito a sua contribuição com o fórum, ANDERSON, leia as regras, como poderá ver, não é permitido pedir algoritmos prontos aqui.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
ANDERSON
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 30
Localização : Brasil
Data de inscrição : 10/11/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Seg Nov 19, 2007 5:05 pm

Eu n tou pedindo pra fazer pra mim n...apezar de ter que entregar isso hj...eu so tou pedindo ajuda pra eu fazer, alguma dica...pois como eu ja disse tenho muitas restrições pra fazer esse algoritimo...so posso usar Comando de Desvio Condicional e Comando de Seleção Múltipla e n tou conseguindo fazer...

minha intenção é aprender n, passar sem saber...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gfilho
Novato
Novato


Masculino
Número de Mensagens : 39
Idade : 28
Localização : Rio Branco
Data de inscrição : 15/11/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Seg Nov 19, 2007 7:48 pm

Anderson, queria muito poder te ajudar com mais que uma simples dica. Porem tambem estou no comeco do meu curso, so vii um metodo para ordenacao de vetor que e o metodo conhecido como "metodo da bolha". Vou estudar mais sobre o assunto para tentar te ajudar. Qualqer coisa posto aqui.

abracos
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Ter Nov 20, 2007 9:11 pm

Oi ANDERSON,

nos forneça alguns exemplos desta estrutura, eu desconheço por esse nome, assim eu poderei te ajudar.

Você ainda não deve ter aprendido "VETOR", que nada mais é que uma variável com diversas posições, por exemplo:
Um vetor de 5 posições, substitui 5 variáveis.

No seu caso terei que usar 5 variáveis correto?

Já que não posso usar loop, nem vetor, terei que fazer apenas com "SE", estou certo?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Qua Nov 21, 2007 12:56 pm

Você pode fazer isso perfeitamente, porém usando uma maior (bem maior) quantidade de 'Se'.

Você lerá cada número e verificará se ele é menor que os números que o usuário já digitou, e se for menor, eles devem trocar de posição, pois numa ordem crescente os menores vêm antes (duh! Rolling Eyes).
Observe este trecho:

leia (n1)
leia (n2)
se (n2 < n1) entao
a <- n1
n1 <- n2
n2 <- a
fimse
escreval ("ordem crescente")
escreval (n1)
escreval (n2)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Sex Nov 23, 2007 9:41 am

Cara vou te ajudar com um exemplo de um algoritmo que eu fiz para ordenar em ordem crescente.
Para ordem descrescente faça o procedimento contrário no lugar do sinal de maior > você coloca o sinal menor <

algoritmo "semnome"
// Função :
// Autor :
// Data : 17/9/2007
// Seção de Declarações
var
a,b,c : real
inicio
// Seção de Comandos
escreva("Digite os valores: ")
leia(a,b,c)
Se (a > b) e (b > c) entao
escreva(a,b,c)
senao
Se (a > c) e (c> b) entao
escreva(a,c,b)
senao
Se (b > a) e (a> c) entao
escreva(b,a,c)
senao
Se (b > c) e (c> a) entao
escreva(b,c,a)
senao
Se (c > b) e (b > a) entao
escreva(c,b,a)
senao
Se (c > a) e (a> b) entao
escreva(c,a,b)
senao
fimse
fimse
fimse
fimse
fimse
fimse
fimalgoritmo


Última edição por em Sex Nov 23, 2007 9:46 am, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Sex Nov 23, 2007 9:42 am

Administradores e permido postar algoritmos inteiros como exemplo?
Eu só deu um exeplo de um algoritmo que eu fiz mais não disse como ordenar 5 numeros.
E mais uma divida ordem crescente o sinal e > ou <?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Sex Nov 23, 2007 5:30 pm

Desde que não seja exatamente o que ele quer, é liberado sim.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Sab Nov 24, 2007 9:23 am

Obrigado
E o meu algoritmo esta correto?
Assim as outras pessoas poderam ver a lógica e tentar ordenar os numeros.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Sab Nov 24, 2007 12:27 pm

Está correto sim. É só testar. Na verdade ele está ordenando em ordem decrescente.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ANDERSON
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 30
Localização : Brasil
Data de inscrição : 10/11/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Sab Nov 24, 2007 8:57 pm

valeu...vcs mim ajudaram muito, ja aprendi a fazer...pena que n deu tempo pra entregar...

Admin poderia explicar melhor VETOR?

valeu...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ANDERSON
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 30
Localização : Brasil
Data de inscrição : 10/11/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Sab Nov 24, 2007 9:08 pm

sim e como seria com looping?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Por em ordem crescente e descrecente   Dom Nov 25, 2007 4:32 am

Olá, aposto que você quer aprender antes do professor ensinar, isso é bom, demonstra interesse. Tá, vou passar um exemplo de algoritmo com vetor e looping, os dois juntos são bem comuns, também explicarei passo a passo:

algoritmo "semnome"
// Função :
// Autor :
// Data : 25/11/2007
// Seção de Declarações
var

vet : vetor [1..10] de inteiro //neste caso, o vetor tem 10 posições, ou seja substitui 10 variáveis, o vetor vai da posição 1 até a posição 10
i : inteiro //contador
a : inteiro

inicio
// Seção de Comandos

para i de 1 ate 10 faca //esse é um looping, nesse caso a variável 'i' vai receber +1 para cada repetição, e tudo que estiver dentro dele vai repetir até que o loop esteja "satisfeito", nesse caso até a variável 'i' ter o valor 10
a <- a + 1
vet[i] <- a // aqui o vetor está na posição da variável 'i', ex: se o 'i' estiver valendo 1, o vetor vai estar na posição 1 e assim por diante.
escreva (vet[i]) // coloco o escreva no loop para que ele a cada repeição na devida posição
fimpara //necessário para encerrar o looping a repetição termina aqui.



fimalgoritmo


Para entender melhor o looping, utilize a ferramente passo a passo, apertando o f8 para cada passo, a cada repetição veja os valores que cada variável recebe, ajuda muito na compreensão.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Por em ordem crescente e descrecente   

Voltar ao Topo Ir em baixo
 
Por em ordem crescente e descrecente
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» mês em ordem crescente
» Visual G - Vetor decrescente
» CLASSIFICAR EM ORDEM CRESCENTE NO FORMULÁRIO
» Ordem do menu de navegação
» Problema na ordem das mensagens em um tópico

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: