VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Vetor

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Thiago
Novato
Novato
avatar

Masculino
Número de Mensagens : 13
Idade : 33
Localização : minas gerais
Data de inscrição : 10/11/2007

MensagemAssunto: Vetor   Seg Nov 19, 2007 8:54 am

Carregar um vetor de 6 elementos, mostrar a quantidade de pares, a quantidade de ímpares e mostrar quais os números são pares e quais são os impares. Consegui somente a quantidade.. Crying or Very sad

var
x:vetor[0..6] de inteiro
i,par,impar:inteiro
inicio
para i de 1 ate 6 faca
leia(x[i])
fimpara
para i de 1 ate 6 faca
se x[i]mod 2 = 0 entao
par<- par + 1
senao
impar<- impar+1
fimse
fimpara
escreval(par," pares")
escreval(impar," impares")
fimalgoritmo

Obrigado
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Vetor   Seg Nov 19, 2007 5:00 pm

Crie outros dois vetores, um para números pares, outro para números ímpares. Utilize a mesma posição ('i'). Utilize também a mesma condição para saber se o número é par ou impar, e faça o devido vetor receber o valor. Veja:
Thiago escreveu:

var
x:vetor[0..6] de inteiro
i,par,impar:inteiro
inicio
para i de 1 ate 6 faca
leia(x[i])
fimpara
para i de 1 ate 6 faca
se x[i]mod 2 = 0 entao
par<- par + 1
senao
impar<- impar+1
fimse
fimpara
escreval(par," pares")
escreval(impar," impares")
fimalgoritmo
var
x:vetor[0..6] de inteiro //você pode criar os outros dois vetores iguais a esse
i,par,impar:inteiro
inicio
para i de 1 ate 6 faca
leia(x)
fimpara
para i de 1 ate 6 faca
se x[i]mod 2 = 0 entao
par<- par + 1
senao
[i]//aqui você faz com que o vetor par na devida posição receba esse valor

impar<- impar+1
//e aqui o ímpar deve receber o valor
fimse
//Você pode escrever aqui o valor, mas eu prefiro fazer um outro loop para uma melhor organização.
fimpara
escreval(par," pares")
escreval(impar," impares")
fimalgoritmo


Se você deseja que o algoritmo não escreva os "0" (zeros), crie uma condição para isso.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Thiago
Novato
Novato
avatar

Masculino
Número de Mensagens : 13
Idade : 33
Localização : minas gerais
Data de inscrição : 10/11/2007

MensagemAssunto: Re: Vetor   Seg Nov 19, 2007 8:54 pm

ok obrigado
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Vetor   Seg Nov 19, 2007 9:13 pm

Resolvido?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Thiago
Novato
Novato
avatar

Masculino
Número de Mensagens : 13
Idade : 33
Localização : minas gerais
Data de inscrição : 10/11/2007

MensagemAssunto: Re: Vetor   Seg Nov 19, 2007 11:33 pm

REsolvido..mais uma vez agradeço !
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Vetor   

Voltar ao Topo Ir em baixo
 
Vetor
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Visual G - Vetor decrescente
» [EPS]Damask Frames-Stock Vector

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: