VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 BUSCAR

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
brmarcus
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 27
Localização : fabriciano
Data de inscrição : 14/11/2007

MensagemAssunto: BUSCAR   Qua Nov 21, 2007 7:16 pm

COMO FAÇO PARA BUSCAR UM FILME NO MEU ALG???
TO CONSEGUINDO NAO?
AJUDA AEEE

funcao buscafilme( ):inteiro
filme:caracter
i,achei:caracter
leia (filme)
se (filme=cat[1,i]) entao
escreval("ACHEI")
achei<-i
fimpara
retorne(achei)
fimfuncao
var
titulo:caracter
i,achei:caracter
inicio
leia (titulo)
se (titulo = (cat1[i,1])) entao
achei<-i
fimpara
retorne(achei)
fimfuncao
funcao buscafilmed( ):inteiro
var
diretor:caracter
i,achei:caracter
inicio
leia (diretor)
se (diretor = cat1[i,2]) entao
achei<-i
fimpara
retorne(achei)
fimfuncao
funcao buscafilmeg( ):inteiro
car
genero:caracter
inicio
i,achei:caracter
leia (genero)
se (genero = cat1[i,3]) entao
achei<-i
fimpara
retorne(achei)
fimfuncao
funcao buscafilmec( ):inteiro
var
codigo:caracter
i,achei:caracter
inicio
leia (codigo)
se (codigo = cat[i]) entao
achei<-i
fimpara
retorne(achei)
fimfuncao
var
cat1:vetor[1..5,1..4] de caracter
valorfilme:vetor[1..5] de real
cat2:vetor[1..5] de inteiro
i,d :inteiro
inicio
para i de 1 ate 5 faca
escreval ("Titulo")
leia (cat1[i,1])
escreval("_________________________________________________________________")
escreval("Diretor")
leia (cat1[i,2])
escreval("_________________________________________________________________")
escreval ("Genero")
leia (cat1[i,3])
escreval("_________________________________________________________________")
escreval ("Código")
leia (cat1[i,4])
escreval("_________________________________________________________________")
escreval("Preço")
leia (cat2[i])
escreval("_________________________________________________________________")
fimpara
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: BUSCAR   Qui Nov 22, 2007 11:00 am

Tem que ser com função?
Se puder ser sem função você poderia colocar todas as características dos filmes em vetores, e fazer uma busca pelos vetores. Observe:

escreva ("Digite o nome do filme a ser buscado: ")
leia (busca)

para i de 1 ate (numero de filmes) faca
se (busca = nomefilme[i]) entao
//encontrou
//exibindo:
escreval (nomefilme[i])
escreval (generofilme[i])
escreval (outrasCoisasDoFilme[i])
interrompa
fimse
fimpara
Voltar ao Topo Ir em baixo
Ver perfil do usuário
brmarcus
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 27
Localização : fabriciano
Data de inscrição : 14/11/2007

MensagemAssunto: Re: BUSCAR   Qui Nov 22, 2007 5:49 pm

O busca tem q ser declarado como caracter ne??
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: BUSCAR   Sex Nov 23, 2007 5:30 pm

Sim para que ele pesquise pelo nome.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
brmarcus
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 27
Localização : fabriciano
Data de inscrição : 14/11/2007

MensagemAssunto: Re: BUSCAR   Sex Nov 23, 2007 6:59 pm

olha ai como fico fiz algumas motificaçoes e da dando errado tem como corrigir




var
cat1:vetor[1..5,1..5] de caracter
cat2:vetor[1..5] de inteiro
i :inteiro
achou:logico

busca:caracter
inicio
para i de 1 ate 5 faca
escreval ("Titulo")
leia (cat1[i,1])
escreval("Diretor")
leia (cat1[i,2])
escreval ("Genero")
leia (cat1[i,3])
escreval ("Código")
leia (cat2[i])
fimpara
escreva ("Digite o nome do filme a ser buscado: ")

para i de 1 ate 5 faca
achou<- falso
leia (busca)
fimpara
se (busca = cat1[i,i])entao
leia(busca)
achou<-verdadeiro
escreval ("filme é", cat1[i,i])
senao
leia(busca)

Escreval ("filme encontrado",busca )

fimse


fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: BUSCAR   Sab Nov 24, 2007 10:40 am

Agora ficou melhor ^^

Mas...você criou uma matriz [1..5,1..5], porém seria necessário apenas uma matriz [1..5,1..3] (Na verdade nem precisava ser com matriz, mas ficou bom desse jeito).

Agora o erro principal é este trecho da busca:

Citação :
para i de 1 ate 5 faca
achou<- falso
leia (busca)
fimpara
se (busca = cat1[i,i])entao
leia(busca)
achou<-verdadeiro
escreval ("filme é", cat1[i,i])
senao
leia(busca)
Escreval ("filme encontrado",busca )
fimse

Tire o 'leia (busca)' de dentro do 'para' e coloque-o antes, afinal, você quer buscar 1 filme, não 5 (se você quiser que o usuário fique buscando filmes e o programa cesse apenas quando ele quiser, terá que usar 'enquanto', e não 'para')

Tire o 'achou <- falso' de dentro do 'para'

Troque tudo que conter cat1[i,i] neste trecho por cat1[i,1], pois todos os nomes de filmes estão em posição 1 (1,1......2,1......3,1...etc)

A comparação 'se (busca = cat1[i,1]) entao' deveria estar dentro do 'para'

Ao invés de usar 'senão', coloque fora do 'para' uma comparação assim: 'se (achou <> verdadeiro) entao'
escreval ("Filme não encontrado")
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: BUSCAR   

Voltar ao Topo Ir em baixo
 
BUSCAR
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Buscar tema no hitskin
» Ferramenta "buscar"
» Como personalizar o meu "buscar" da minha página inicial?
» Buscar novo da forumeiros
» Personalizar o buscar

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: