VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Jogo da velha

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Jogo da velha   Ter Nov 27, 2007 10:22 am

Eu estou a criar um jogo da velha para 2 jogadores humanos
E estou com dúvida de como fazer.
Eu sei que preciso de uma matriz 3x3
Eu sei que preciso usar o comando escolha
O comando se
Só não sei montar o jogo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Jogo da velha   Ter Nov 27, 2007 7:34 pm

Você precisa de efeitos visuais?

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Jogo da velha   Qua Nov 28, 2007 8:46 am

Não preciso de efeitos visuais.

Só uma dúvida efeitos visuas só da pra fazer em C não e?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Jogo da velha   Qua Dez 19, 2007 6:08 pm

Eu comecei a fazer esta correto o que eu estou fazendo?

algoritmo "semnome"
// Função :
// Autor :
// Data : 19/12/2007
// Seção de Declarações
var
matrix : vetor[1..3,1..3] de real
i,j : inteiro
x,y : inteiro
inicio
// Seção de Comandos

//Verifica as linhas
para i de 1 ate 3 passo
se (matrix[i,1] = matrix[i,2]) e (matrix[i,3] = matrix[i]) entao
escreva(matrix[i])
fimse
//Verifica as colunas
para i de 1 ate 3 passo
se (matrix[1,i] = matrix[2,i]) e (matrix[3,i] = matrix[i]) entao
escreva(matrix[i])
fimse

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Jogo da velha   

Voltar ao Topo Ir em baixo
 
Jogo da velha
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Jogo da velha
» Jogo de Batalha Bíblica e Jogo da Memória (Shareware)
» Cara chora jogando jogo assustador.
» A - Mimomee - Jogo inteiro feito com Drag and Drop
» Jogo dos parceiros

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: