VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ajuda para Sub-rotina do tipo Procedimento

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
adriana
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 40
Localização : DF
Data de inscrição : 02/05/2008

MensagemAssunto: Ajuda para Sub-rotina do tipo Procedimento   Qui Maio 15, 2008 9:27 pm

Estou em dificuldades para implementar um exercício que usa sub-rotina do tipo procedimento passando o parâmetro por referência. O código por valor eu consegui fazer. O professor falou que na hora de imprimir, a parte do código estaria em loop, mas não estou conseguindo fazer. Pensei em utilizar vetor para ir acumulando os valores, já que como são variáveis locais assim que acaba o cálculo o procedimento é zerado, mas não está dando certo, pois o Visulag dá a mensagem que não reconhece o tipo de dados vetor. Aonde estou errando?

Segue o enunciado e o código:

Desenvolva o algoritmo abaixo e sua sub-rotina do tipo procedimento. O problema deverá ser resolvido usando passagem de parâmetro por valor e por referência.


procedimento FIBONACCI(N: inteiro; var NOVOTERMO: vetor [1..N] de real)
var
CONT, TERMO1, TERMO2:inteiro
inicio
TERMO1 <- 1
TERMO2 <- 0
para CONT de 1 ate N faca
NOVOTERMO [CONT] <- TERMO1 + TERMO2
TERMO1 <- TERMO2
TERMO2 <- NOVOTERMO
fimpara
fimprocedimento

var
RETORNO: vetor [1..N] de real
CONT, LIMITE: inteiro
inicio
escreva ("Informe um valor: ")
leia (LIMITE)
para CONT de 1 ate LIMITE faca
FIBONACCI(LIMITE,RETORNO [LIMITE])
escreval ("O termo", CONT, " da série Fibonacci é: ", RETORNO [LIMITE])
fimpara
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Ajuda para Sub-rotina do tipo Procedimento
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Ajuda para impedir que o banner ou logo redimensione, preciso travá-lo de acordo com o tamanho do fórum
» Ajuda para criar uma barra de inicio "gostosa"
» Ajuda para editar codigo de chat box personalizado
» Ajuda para colocar o xat
» Ajuda para mudar de dominio personalizado

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: