VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 pesquisa dentro do alg (urgente)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Kabal_
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 27
Localização : MG
Data de inscrição : 13/06/2008

MensagemAssunto: pesquisa dentro do alg (urgente)   Sex Jun 13, 2008 8:43 pm

o problema é o seguinte

Faça um algoritmo para armazenar em um vetor de 100 posições as placas dos carros de um edifício, e em outro vetor o nome do dono da vaga. O índice de cada posição dos dois vetores corresponde ao número da vaga na garagem do edifício. Depois solicite ao usuário o número de uma placa de carro ou o nome de um morador e pesquise e informe qual o número da sua vaga.

mas nao estou conseguindo fazer ele pesquisar =\

preciso disso feito ateh domingo!! me ajudem....
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: pesquisa dentro do alg (urgente)   Qua Jun 18, 2008 5:04 pm

Pergunte ao usuario o nome ou a placa.
Usando um laço de repetição, compare a resposta do usuario com cada elemento dos vetore, e caso seja igual, retorne a posição do vetor (que é o valor da variável contadora do laço), pois a posição do vetor é a vaga correspondente.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Danilo Mendes
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 21
Localização : Londrina-PR
Data de inscrição : 04/11/2012

MensagemAssunto: Re: pesquisa dentro do alg (urgente)   Dom Nov 25, 2012 2:01 pm

algoritmo "Garagem"
var
vnome: vetor [1..2] de caractere
Vplaca: vetor [1..2] de caractere
placa,nome:caractere
y:inteiro
opcao,posi:inteiro
resp:logico
inicio
escreval("--->>> Garagem <<<---")
escreval(" ")
escreval("****** CADASTRO ******")
escreval(" ")
para y de 1 ate 2 faca
escreval("Digite a placa do veiculo:")
leia(vplaca[y])
escreval("Digite o nome do dono da vaga:")
leia(vnome[y])
fimpara
escreval("--->>> Garagem <<<---")
escreval(" ")
escreval("****** CONSULTA ******")
escreval(" ")
escreval("Digite 1*Consulta Placa 2*Consulta Nome")
leia (Opcao)
escolha opcao
caso 1
escreval("Consulta por Placa")
escreval("Digite a Placa: ")
leia(placa)
para y de 1 ate 2 faca
se placa = vplaca[y] entao
resp <- verdadeiro
posi <- y
fimse
fimpara
se (resp = verdadeiro) entao
escreval (posi,"- posição")
senao
escreval("placa nao existe")
fimse
caso 2
escreval("Consulta por Nome: ")
escreval("digite o nome: ")
leia (nome)
para y de 1 ate 2 faca
se nome = vnome[y] entao
resp <-verdadeiro
posi <- y
fimse
fimpara
se (resp = verdadeiro) entao
escreval (posi,"- posição")
senao
escreval("nao existe")
fimse
fimpara
outrocaso
escreval("Opção invalida")
fimescolha
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: pesquisa dentro do alg (urgente)   

Voltar ao Topo Ir em baixo
 
pesquisa dentro do alg (urgente)
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: