VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 penúlitimo e antepenúltimo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
beto augsten
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 46
Localização : Gramado
Data de inscrição : 12/07/2008

MensagemAssunto: penúlitimo e antepenúltimo   Dom Jul 13, 2008 8:39 pm

Boa noite!!
Preciso fazer um algoritmo que seja possivel digitar números até ser digitado 0 (zero) e apresentar o penúltimo e antepenúltimo numero digitado. Tentei várias maneiras, mas não descobri qual a sintaxe que faz este controle. se alguem puder me dar uma dica agradeço.
ATT Roberto Gramado -RS
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: penúlitimo e antepenúltimo   Sex Ago 22, 2008 2:02 pm

Use o comando

repita

aqui vai o seu código

ate (n=0)

Espero ter ajudado

Abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
JuniOr
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 30
Localização : Minas Gerais
Data de inscrição : 24/01/2009

MensagemAssunto: Re: penúlitimo e antepenúltimo   Sab Jan 24, 2009 7:52 pm

Espero ter ajudado a tempo.

algoritmo "Antepenultimo Penultimo"
// Função : Mostrar Antepenultimo e penultimo
// Autor : JuniOr
// Data : 24/1/2009
// Seção de Declarações
var
u,p,a:inteiro
inicio
escreva("Digite um número:")
leia(u)
enquanto u <> 0 faca
a<-p
p<-u
escreva("Digite um número:")
leia(u)
fimenquanto
escreval("antepenultimo: ",a)
escreval("penultimo: ", p)
escreval("ultimo, claro:", u)
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: penúlitimo e antepenúltimo   

Voltar ao Topo Ir em baixo
 
penúlitimo e antepenúltimo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: